Dynamic Talkgroups "None" still receiving

Help with DMR issues
WY0X
Posts: 5
Joined: Sat Sep 07, 2019 2:00 am

Re: Dynamic Talkgroups "None" still receiving

Post by WY0X »

Interesting discussion.

Now y'all know why I found it really odd that the pi-star was transmitting stuff from a group it wasn't showing at all anymore! Haha.

Appreciate the heads up on the hover-over text on the BM website. That may have been a clue about what oddball state it all somehow got into. I likely would have never found that.
n7ekg
Posts: 10
Joined: Tue Nov 02, 2021 3:01 pm

Re: Dynamic Talkgroups "None" still receiving

Post by n7ekg »

Obviously, you haven't bothered to read Toshens documentation either.
To avoid any sharp answers of this type, *I* bothered to read it.
You are mistaken. REFRESH the dashboard and look again. Every talk group I've ever keyed on a simplex setup gets added AND DISPLAYED in the dynamic column of the Admin page when you have the BM API key installed. Remember this info COMES from BM, NOT from the hotspot.
I got into the exact same situation this evening, but I don't have any static talkgroups defined, and I removed all the auto-static ones via the BM Manager on the Admin page, THEN I went to the BM website and actually looked for myself. BM shows NO talkgroups, either static or auto-static.

This is what I saw:
Screenshot from 2021-11-10 02-18-31.png
Screenshot from 2021-11-10 02-18-31.png (171.71 KiB) Viewed 392 times
Please note that there are no static or auto-static talkgroups showing here.

The hotspot should *not* be transmitting, yet it defaults to the last talkgroup, even if I remove it. Went through this many times this evening - when I finally rebooted the hotspot, all was back to normal. It appears that this is either an MMDMV or Pi-Star issue, NOT a BM one.

Interesting behavior. I'm not sure where to look for this, though - it could be in the MMDMV firmware, or somewhere in the Pi-Star code itself. A reboot resolved the issue, yet this is a less-than-optimal solution.
n7ekg
Posts: 10
Joined: Tue Nov 02, 2021 3:01 pm

Re: Dynamic Talkgroups "None" still receiving

Post by n7ekg »

Here's another example, after a reboot. Please not the talkgroup reverted to the last one that was used, but according to BM, there are no static or auto-static talkgroups.
Screenshot from 2021-11-10 05-28-06.png
Screenshot from 2021-11-10 05-28-06.png (153.74 KiB) Viewed 388 times
KE7FNS
Pi-Star Team
Posts: 2293
Joined: Wed Apr 17, 2019 11:11 pm

Re: Dynamic Talkgroups "None" still receiving

Post by KE7FNS »

n7ekg wrote: Wed Nov 10, 2021 8:21 am The hotspot should *not* be transmitting, yet it defaults to the last talkgroup, even if I remove it. Went through this many times this evening - when I finally rebooted the hotspot, all was back to normal.
You are supposed to key up 4000 when you no longer wish to monitor a talkgroup. That should remove it from the list FOR YOU AND stop sending you talkgroup network transmissions.
n7ekg wrote: Wed Nov 10, 2021 8:21 am It appears that this is either an MMDMV or Pi-Star issue, NOT a BM one.
And your proof is where??

n7ekg wrote: Wed Nov 10, 2021 8:21 am Interesting behavior. I'm not sure where to look for this, though - it could be in the MMDMV firmware, or somewhere in the Pi-Star code itself. A reboot resolved the issue, yet this is a less-than-optimal solution.
MMDVM firmware is stand alone and has no means to do any network communications, it only communicates with MMDVMHost using RS-232 serial or USB. Theres nothing in any "Pi-Star code" that has anything to do with this.

This is completely handled by BM.

From what you've posted I believe the issue is caused by you removing talkgroups from the listing and not keying up 4000 to drop them when you no longer wish to monitor a talkgroup.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
n7ekg
Posts: 10
Joined: Tue Nov 02, 2021 3:01 pm

Re: Dynamic Talkgroups "None" still receiving

Post by n7ekg »

You are supposed to key up 4000 when you no longer wish to monitor a talkgroup. That should remove it from the list FOR YOU AND stop sending you talkgroup network transmissions.
That was done. Several times.
Last edited by n7ekg on Wed Nov 10, 2021 8:56 pm, edited 1 time in total.
n7ekg
Posts: 10
Joined: Tue Nov 02, 2021 3:01 pm

Re: Dynamic Talkgroups "None" still receiving

Post by n7ekg »

It appears that this is either an MMDMV or Pi-Star issue, NOT a BM one.
And your proof is where??
By the simple, and quite logical, fact that when the Pi is rebooted, the problem goes away. Logically, if it were a BM issue, it would survive between reboots.

That's my proof.
KE7FNS
Pi-Star Team
Posts: 2293
Joined: Wed Apr 17, 2019 11:11 pm

Re: Dynamic Talkgroups "None" still receiving

Post by KE7FNS »

n7ekg wrote: Wed Nov 10, 2021 8:20 pm That was done. Several times.
I saw no mention of it in your posts or in your screen grabs.
n7ekg wrote: Wed Nov 10, 2021 8:26 pm By the simple, and quite logical, fact that when the Pi is rebooted, the problem goes away. Logically, if it were a BM issue, it would survive between reboots.

That's my proof.
Nope. Completely different session due to the reconnection.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
Post Reply