Dashboard connection drop

All IP networking related issues
Post Reply
AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Dashboard connection drop

Post by AA5I » Thu Jul 18, 2019 1:08 pm

After a few hours of none activity on the MMDVM hotspot I got from Amazon, I am not able to connect to the web interface. It is still connected to the internet and I can still use my radio. To get the dashboard back I have to reboot the hotspot. When I go into ipscan I do not see the IP address listed. After I reboot it is back. Any settings that may not be correct?

Gary

AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Re: Dashboard connection drop

Post by AA5I » Sat Jul 20, 2019 12:59 pm

I guess that no one has an idea why this is doing this. It does it about twice a day and I have to reboot the unit.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Dashboard connection drop

Post by KE0FHS » Sat Jul 20, 2019 4:52 pm

If your hotspot is losing connectivity after running for awhile, one thing to check is whether WiFi Power Save is on:

Code: Select all

iw wlan0 get power_save
If it is on, see the post in the Pi-Star User Forum by Albert, AF4FA, for some helpful suggestions:
viewtopic.php?f=3&t=1726#p7603
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Re: Dashboard connection drop

Post by AA5I » Sat Jul 20, 2019 7:52 pm

Toshen,

My power save WAS on. I edited the file per instructions you sent, and I will keep you updated. Many thanks,

73,
Gary, AA5I

AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Re: Dashboard connection drop

Post by AA5I » Sun Jul 21, 2019 11:04 am

Did not fix it. This morning got up and could not connect again to dashboard. Had to power off and back on the unit.

Gary

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Dashboard connection drop

Post by KE0FHS » Sun Jul 21, 2019 12:11 pm

You may need to explore the configuration options for your router.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Re: Dashboard connection drop

Post by AA5I » Sun Jul 21, 2019 1:26 pm

I have other devices that go through the same wireless router with no problems. Why would just quit working after a few hours of non-activity? It works for hours after I reboot the MMDVM. I notice that the port used for radio traffic is on interface 0 so the dashboard must be on 1. I can still use the radio, so the radio traffic has to still be going through the router.

AF6VN
Posts: 271
Joined: Fri Jul 20, 2018 1:15 am

Re: Dashboard connection drop

Post by AF6VN » Sun Jul 21, 2019 4:56 pm

AA5I wrote:
Sun Jul 21, 2019 1:26 pm
I have other devices that go through the same wireless router with no problems. Why would just quit working after a few hours of non-activity? It works for hours after I reboot the MMDVM. I notice that the port used for radio traffic is on interface 0 so the dashboard must be on 1. I can still use the radio, so the radio traffic has to still be going through the router.
<blink><blink>

There should just be one WiFi interface between router and Pi-Star. It carries all traffic -- the router is responsible for directing it to the WAN or LAN based upon (ignoring WiFi wrapping of Ethernet packets) the IP address contained in the Ethernet packet (the IP address identifies the end point, while MAC addresses tend to be used to identify the next node in the chain).

Do you use those "other devices" to talk to each other inside the LAN? Or are they only going out the WAN? If the latter, you have not proven anything, since you claim the Pi-Star system also is still going out to the WAN.

What is the DHCP lease expiration period for stuff on your LAN? Is there any chance the Pi-Star is getting a DHCP lease renewal which is for some reason getting a new IP # each time -- while your Windows box has cached the old IP #? Does flushing caches on the Windows do anything?

https://www.technipages.com/flush-and-r ... g-ipconfig

If flushing the cache (and maybe also use whatever option you have in your browser too, to flush its caches) lets Windows recover the Pi-Star, you might want to see about configuring a static IP # in the router tied to the Pi-Star WiFi MAC address -- so it always gets the same IP #.

--
AF6VN
Dennis L Bieber

AA5I
Posts: 8
Joined: Tue Jul 16, 2019 2:52 pm

Re: Dashboard connection drop

Post by AA5I » Sun Jul 21, 2019 5:25 pm

Not sure but I noticed that the Pi-Star has 2 network ports, 0 and 1. I have both set to off for power save. I assume the in the etc/host file I could set a static IP address but that means that if I take it to the car it will not work. I have set a static IP address of 192.168.0.14 for the Pi-Star, and it always uses that address on power up. If this is not correct let me know what I need to change.

AF6VN
Posts: 271
Joined: Fri Jul 20, 2018 1:15 am

Re: Dashboard connection drop

Post by AF6VN » Mon Jul 22, 2019 2:17 pm

AA5I wrote:
Sun Jul 21, 2019 5:25 pm
Not sure but I noticed that the Pi-Star has 2 network ports, 0 and 1. I have both set to off for power save. I assume the in the etc/host file I could set a static IP address but that means that if I take it to the car it will not work. I have set a static IP address of 192.168.0.14 for the Pi-Star, and it always uses that address on power up. If this is not correct let me know what I need to change.

Code: Select all

[email protected](ro):~$ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:1e:5e:80
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2294214 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2294214 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:115537642 (110.1 MiB)  TX bytes:115537642 (110.1 MiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:4b:0b:d5
          inet addr:192.168.1.79  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3962672 errors:0 dropped:0 overruns:0 frame:0
          TX packets:740300 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:378123197 (360.6 MiB)  TX bytes:80357303 (76.6 MiB)

[email protected](ro):~$
One Ethernet (RJ-45) interface and one WiFi interface. Mine is located in the living room quite distant from my router, so has no cable connection. (Strange -- the other R-Pi used as a web server, which IS cabled, showed both eth0 and wlan0 having IP addresses; somehow the crontab to take down wlan0 on boot didn't take -- I don't need the WiFi congestion for a cabled system)



Most ROUTERS have a feature where one can lock a DHCP IP address to a specific MAC (hardware) address. That way, whenever the device connects to the router, the router will give it the same IP each time. From mine:
Help

The IP Allocation table lists DHCP clients and IP Allocated clients. You may want to create an IP Allocated client so that it will always get the same IP address. The IP Allocated clients are still configured as DHCP clients at the client end, but will always be served the same IP address by the device DHCP server.

--
AF6VN
Dennis L Bieber

Post Reply