UPNP MikroTik hAPac2

All IP networking related issues
Post Reply
User avatar
VK7HSE
Posts: 172
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

UPNP MikroTik hAPac2

Post by VK7HSE » Thu Jul 25, 2019 5:20 am

I recently had a router die and I opted to replace it with the above mentioned.

So I've got upnp enabled for pi-star and it's enabled in the MikroTik router. What seems to be happening is that after about 2 minutes my C4FM, NXDN & P25 all drop their respect reflectors that they are setup to use.

My guess this is going to be something within the MikroTik router than pi-star, but just wondering if anyone else has noticed this behaviour?

All you hotspots are running 4.1 rc3 and are left on 24/7 so they receive nightly updates.

All reflectors are set as static startup with no time out or reconnect after x minutes. So I'm just a little bit baffled as to what is going on, is the router enforcing a rule that I'm unaware of and that's impacting on the hotspots...

Keen to hear what you think about this issue

Sent from my Pixel 2 XL using Tapatalk


Last edited by VK7HSE on Thu Jul 25, 2019 5:20 am, edited 1 time in total.

User avatar
w7efs
Posts: 305
Joined: Sun Apr 22, 2018 4:26 pm

Re: UPNP MikroTik hAPac2

Post by w7efs » Fri Jul 26, 2019 6:42 pm

One should always first examine the log files for clues. Click the "Live Logs" link in the uppermost block on the Admin page before the problem develops. You can highlight the text of concern if any, then Ctrl-c to copy it and Ctrl-v to paste it into your reply.

User avatar
MW0MWZ
Site Admin
Posts: 916
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: UPNP MikroTik hAPac2

Post by MW0MWZ » Thu Aug 01, 2019 8:07 am

VK7HSE wrote:
Thu Jul 25, 2019 5:20 am
I recently had a router die and I opted to replace it with the above mentioned.

So I've got upnp enabled for pi-star and it's enabled in the MikroTik router. What seems to be happening is that after about 2 minutes my C4FM, NXDN & P25 all drop their respect reflectors that they are setup to use.

My guess this is going to be something within the MikroTik router than pi-star, but just wondering if anyone else has noticed this behaviour?

All you hotspots are running 4.1 rc3 and are left on 24/7 so they receive nightly updates.

All reflectors are set as static startup with no time out or reconnect after x minutes. So I'm just a little bit baffled as to what is going on, is the router enforcing a rule that I'm unaware of and that's impacting on the hotspots...

Keen to hear what you think about this issue

Sent from my Pixel 2 XL using Tapatalk
I dont *think* this is a uPNP issue, uPNP is used for a limited number of things, D-Star mainly, plus Dashboard / SSH access.
So if you have UPNP on, and dashboard set to public, it will ask for the port forward from the router for port 80, SSH works the same way, if its set to public with UPNP on, it will ask for 22 to be forwarded.

D-Star has some port forward requirements depending on the mode and if you want full call routing etc to work, the modes you are having problems with YSF/NXDN/P25 all dont need the forwards, they all transfer the UDP streams back and forth in the same stream, you might want to look at the session time-outs on the router.

All of the ports in use (and a decent commentary about what they are used for) can be found in the pi-star firewall, the content of that can be seen here: https://github.com/AndyTaylorTweet/Pi-S ... r-firewall

Not used the MicroTik but I would assume you can either make specific service objects for each UDP port you want to use, and maybe there is an option on the service object for the session time-out (extend it to basically never). If you cannot do this for specifically the ports used by the voice traffic - dont just set all the session time-outs to never or you will eventually saturate the session table.

I hope this helps, if not feel free to screen-shot what you have / talk to me about it etc..
Andy

73 de MW0MWZ
http://pistar.uk

User avatar
VK7HSE
Posts: 172
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: UPNP MikroTik hAPac2

Post by VK7HSE » Tue Aug 06, 2019 7:03 pm

Ok just an update on this,

I got a mate to remote login to the router and check the nat rules I'd specified and although I followed the suggested way to setup the router from the MikroTik wiki I hadn't specified an external IP field or the internal destination. Once this was done everything stated working as it should!

Sent from my Pixel 2 XL using Tapatalk


Post Reply