Page 1 of 1

Zumspot RPI dropping talkgroup

Posted: Sat May 16, 2020 12:25 pm
by WA1LMC
I have aZumspot RPI with the Nextion display buillt on a raspberry Pi 3 Over the past 3 weeks, the device is dropping the talk group where it was parked. It happens frequently during discussion groups requiring me to key up my portable to set the talk group again. I have reset to factory defaults then updated the OS and reconfigured the device yet the problem persists. I am hoping you folks have experienced this and devised a fix for the problem. Although the device is on for long periods, it sits on a fan near the room air conditioner so the device is cool (about 99.5 degrees F) but even after a overnight rest, this situation occurs even when the device is first turned on.

Any thoughts?

Re: Zumspot RPI dropping talkgroup

Posted: Sat May 16, 2020 1:42 pm
by M1DNS
If it's a duplex board, that would be correct. They mimic a repeater setup and time out after abt 15mins. Unlike a simplex board which stays semi-static with the last dynamic keyed.

Sent from my SM-G935F using Tapatalk


Re: Zumspot RPI dropping talkgroup

Posted: Sat May 16, 2020 1:54 pm
by WA1LMC
That does make sense I suppose but this is a simplex UHF modem. I would expect it to drop an inactive talk group meaning there would be an inactivity timer, but it is either hearing something in the inbound data that may be the cause but that is highly unlikely. I did make the device private and all features under DMR settings are private as well. The real test will be Sunday nights DMR net discussion group. If I get dropped for no reason, then all of my work so far has netted nothing.

Re: Zumspot RPI dropping talkgroup

Posted: Sun May 17, 2020 4:21 pm
by WA1LMC
Also a note: The Zumspot RPI (Nextion Display) has an issue on the Raspberry Pi 3 where after hours, it will not connect to my wifi, so I use my ethernet. However, I noticed that using ADVANCED IP SCANNER I found 2 instances of the same Raspberry Pi on my network...one was wired and one was through the wifi. I shut down the wifi by removing the wifi ID and security key but upon reboot, it loaded both again. Further investigation revealed the raspberry pi is passing date on both wifi and wired at the same time. My fix for now is to disconnect the ethernet and wait for the raspberry Pi to finally aquire a Wifi connection. This Raspberry Pi is one screwed up unit.

Re: Zumspot RPI dropping talkgroup

Posted: Sun May 17, 2020 5:23 pm
by AF6VN
WA1LMC wrote:
Sun May 17, 2020 4:21 pm
Also a note: The Zumspot RPI (Nextion Display) has an issue on the Raspberry Pi 3 where after hours, it will not connect to my wifi, so I use my ethernet. However, I noticed that using ADVANCED IP SCANNER I found 2 instances of the same Raspberry Pi on my network...one was wired and one was through the wifi. I shut down the wifi by removing the wifi ID and security key but upon reboot, it loaded both again. Further investigation revealed the raspberry pi is passing date on both wifi and wired at the same time. My fix for now is to disconnect the ethernet and wait for the raspberry Pi to finally aquire a Wifi connection. This Raspberry Pi is one screwed up unit.
Have you considered adding a crontab entry with time-spec of @reboot, which issues a sudo ifconfig wlan0 down command, since if you are close enough for a cabled connection the cable should be more reliable. And taking wlan0 down should reduce WiFi congestion for other uses...

Re: Zumspot RPI dropping talkgroup

Posted: Sun May 17, 2020 6:18 pm
by M1DNS
If your using it wired.

sudo ifconfig wlan0 down
Should drop the Wi-Fi connection.

But just the same, deleting the entry in the pistar wifi config should kill it also.

Sent from my SM-G935F using Tapatalk


Re: Zumspot RPI dropping talkgroup

Posted: Mon May 18, 2020 4:31 am
by KE7FNS
WA1LMC wrote:
Sat May 16, 2020 12:25 pm
Any thoughts?
More information is needed.

Which version of pi-star you are running?

Also what DMR Network are you trying to use? If you are using Brandmeister, go into your self service settings and enter the TG that you want to be static, if theres multiple talkgroups you are wanting to be static define a schedule because you can't have multiple talkgroups all be active at the same time.
https://amateurradionotes.com/auto-static.htm