Dashboard Doesn't Show Linked in the Morning

Help with YSF / Fusion issues
wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Mon Oct 14, 2019 2:34 pm

I have three hotspots that are linked to FCS00241. They are left turned on overnight. They work fine during the day, but in the morning the dashboard shows that they are no longer linked. If I transmit to any of them with an FT-70D, it shows that it received the transmission, but it remains unlinked and the other two hotspots don't show the transmission. If I go into configuration and click on "apply changes", the hotspot will link to FCS00241 after approximately 30 seconds.

These are Chinese Jumbospots. All of them are running dashboard 20190905 and all of the firmwares are v1.4.17. One of the hotspots is running Pi-Star 4.0.0-RC4 on a Pi 3B+ and two of them are running Pi-Star 4.1.0-RC6 on Pi Zero Ws. I upgraded the firmware on the two hotspots running Pi-Star 4.1.0-RC6 from v1.3.3 and the firmware on the hotspot runninng Pi-Star 4.0.0 from v1.4.12 yesterday and don't remember this problem before I upgraded.

Has anyone seen this? Thanks for any suggestions.

Fred WA0GMH

wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Mon Oct 14, 2019 3:39 pm

My internet provider is doing some work on the system. I noticed that my internet went down a few minutes ago, then came back up. All three of the hotspots became unlinked and did not link to FCS00241 until I either clicked on "apply changes" or rebooted the hotspot.

My Linux knowledge is limited, but does this line in the System Cron re-establish the WiFi link every 5 minutes?

*/5 * * * * root /usr/local/sbin/pistar-upnp.service start > /dev/null 2>&1 &

Fred WA0GMH

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by KE7FNS » Mon Oct 14, 2019 8:03 pm

wa0gmh wrote:
Mon Oct 14, 2019 3:39 pm
My Linux knowledge is limited, but does this line in the System Cron re-establish the WiFi link every 5 minutes?

*/5 * * * * root /usr/local/sbin/pistar-upnp.service start > /dev/null 2>&1 &
No, that is for UPNP, Universal Plug and Play, it is network related, but not for keeping the wifi link up.
All views, comments, posts and opinions shared are entirely my own.

wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Mon Oct 14, 2019 9:06 pm

Universal Plug and Play includes establishing network services. So is UPnP only used when the hotspot is first booted (powered up)? If so, what maintains the link if it drops out temporarily? Most devices will re-establish the link if a connection drops out and comes back.

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by KE7FNS » Tue Oct 15, 2019 1:21 am

wa0gmh wrote:
Mon Oct 14, 2019 9:06 pm
Universal Plug and Play includes establishing network services. So is UPnP only used when the hotspot is first booted (powered up)? If so, what maintains the link if it drops out temporarily? Most devices will re-establish the link if a connection drops out and comes back.

Code: Select all

a network service is an application running at the network application layer and above
The key words there are "application layer and above".

https://en.wikipedia.org/wiki/Internet_protocol_suite

UPNP has nothing to do with initiating network connections, it expects that it has already been done in the Internet layer.

I really don't know if it is only used when the hotspot is first booted. I've never looked into it, I would assume it runs constantly to detect whenever a new device has been discovered.

I don't think anything maintains a wifi link if it drops out.

I think what you are experiencing is that every night when pi-star does its own update, it shuts down MMDVMHost, and therefore that would disconnect you from every connection in all of the modes pi-star supports. I have no idea why it doesn't automatically reconnect like you want it too, I am not familiar with YSF, maybe someone else will contribute and help you on that issue.

I just saw your question about that script and figured I'd let you know what it was.
All views, comments, posts and opinions shared are entirely my own.

wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Tue Oct 15, 2019 2:33 pm

Thanks for the explanation. I've never delved into the TCP/IP network layers. Logically it would seem that something would re-establish a WiFi link if it was temporarily lost. Seeing that the UPnP service was run every 5 minutes looked promising.

I can duplicate the problem by rebooting the wireless router, so a temporary work around is to reboot the hotspot periodically. I've added a line to System Cron to reboot it around 2 am and that seems to be working.

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by KE7FNS » Wed Oct 16, 2019 12:34 am

Who knew that 400 level network protocol class at ASU would eventually be useful.

Like I said I don't think the RPi OS ever detects that the connection has failed and attempts to reestablish the connection. It is a pretty common topic on some of the RPi forums and tech sites. People have devised all sorts of scripts, or recommended installing a network manager like Wicd.

One thing I can think of is there is power save feature that might be enabled, I think in earlier versions of pi-star (3.4.17) it was left on, and I know in 4.1 it is already turned off. If it is on, it could be powering down the wifi.

Code: Select all

iw wlan0 get power_save
If that reports on, you need to follow the instructions on how to turn it off, rather than repeat it, its just easier to send you to Toshens website: https://amateurradionotes.com/pi-star-t ... workissues

If I were you, I'd kick off "sudo pi-star update" and see if it reconnects when it finishes like you want it too. If it does then the nightly update probably isn't the issue. I don't think it is going to be very easy to find.

Good luck.
All views, comments, posts and opinions shared are entirely my own.

wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Mon Oct 21, 2019 2:20 pm

Thanks again. I have another Raspberry Pi running with an APRS hat and it always restarts when the internet is lost or the router reboots. I guess what I need to do is see if I can find a difference in how the networking is set up.

Now I have another problem. The OLED display on a Jumbospot I have worked fine using Pi-Star 4.0.0 and the previous dashboard. After the dashboard upgrade to 20191016 it didn't appear to completely erase the screens when they change. I upgraded to Pi-Star 4.1.1 and thought it was working, but this morning it's doing the same thing. The dashboard is now also completely blank (dark) after the hang time. I no longer see the scrolling MMDVM.

Has any one else seen this?

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Dashboard Doesn't Show Linked in the Morning

Post by KE0FHS » Mon Oct 21, 2019 2:38 pm

wa0gmh wrote:
Mon Oct 21, 2019 2:20 pm
Has any one else seen this?
Dave, KC6N, figured this out: viewtopic.php?f=7&t=2202#p10725

There's a new setting in Expert Editor > MMDVMHost > OLED: LogoScreensaver
By default, it's set to 0. Set to 1 to get the logo back.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

wa0gmh
Posts: 6
Joined: Fri Feb 15, 2019 11:39 pm

Re: Dashboard Doesn't Show Linked in the Morning

Post by wa0gmh » Mon Oct 21, 2019 8:16 pm

Interesting. I tried a hotspot that had not been left on overnight and it worked fine. It does not show a line to enable showing the LogoScreenSaver. It shows the same dashboard version (20191016) and version of Pi-Star (4.1.0-RC6) as the one that doesn't work.

The working hotspot is a Jumbospot hat on a Pi Zero W and the one not working is a Jumbospot hat on a Pi3B+. I had turned on scroll in the expert menu (OLED) to get MMDVM to scroll on the Pi 3B+. This worked fine until this morning.

I just turned on LogoScreenSaver and the OLED still showed gibberish. I turned scroll off (back to 0) and this got rid of the gibberish I saw on the OLED, and it stopped MMDVM from scrolling.

So it appears that if I have scroll on, the OLED does not work properly. MMDVM is shown after the hangtime, but the display of the person calling and the screen showing the IP address are both messed up. It's an easy fix to not have scroll turned on, but I thought someone might be interested in this observation.

Go to UTube and search for KN4KUU. He has videos about stopping the automatic updates and how to automatically reset Pi-Star if you lose network connectivity.

Post Reply