YSFGateway Not Starting

Help with YSF / Fusion issues
W4DHW
Posts: 5
Joined: Sun May 13, 2018 5:19 am

YSFGateway Not Starting

Post by W4DHW »

Was there a fix for this? I assume I have all the config set up correctly. Using RC7, the network option remains red. The mode is green.
KO4AZW
Posts: 7
Joined: Tue Feb 16, 2021 12:48 am

Re: YSFGateway Not Starting

Post by KO4AZW »

Newb, so I don't know if this valid, but it seemed to work for me two days ago, when I setup my pi-star for the first time, ever...

I noticed the same thing, and eventually correlated the General Configuration / Node Callsign "M1ABC" that appeared from a new flash image. I also found that same "M1ABC" in the YSF GW / APRS pane at the bottom of the page. The entry in Description was "M1ABC_Pi-Star_ND"

I replaced the "M1ABC_..." with the callsign that I entered on the first page, leaving the "..._Pi-Star_ND" intact. I applied the settings, and after the pi-star restarted the services, YSF Network block went from Red to Green.

Not that what I did actually effected the change, but everything has been working as expected ever since.

Safe trips,
Dave
KD7F
Posts: 10
Joined: Sat Feb 13, 2021 10:06 pm

Re: YSFGateway Not Starting

Post by KD7F »

I am also fairly new. I am running an MMDVM_HS hat on a Pi 3B+ with the latest Pi Star version (4.1.4) updated today (Dashboard date is 20210212). The hat firmware is 1.5.2. I have the configuration settings set for YSF and YSF2P25 and all seems to work...except when I power up or reboot the YSFGateway service is not green and the YSF Network is indicating "Service Not Started" on the Admin dashboard. If I go to the configuration screen and hit any of the Apply Changes buttons (no settings changed), when the services are restarted the YSFGateway is green and the YSF Network is set to the default startup host set in the configuration (I have it set to the Parrot currently). It seems that somehow the YSFGateway service isn't getting started when the Pi boots up or is rebooted.

Is there a setting that would affect this? I haven't been playing around in the Expert Settings...

I had this same MMDVM_HS hat on a Pi Zero running the same hat firmware and Pi-Star version and it wasn't doing this. I started with a fresh 4.1.4 image on a different 16GB uSD card when I set up the Pi 3B+. I have the Pi 3B+ connected to my router with an ethernet cable. When I saw that the Pi was serving the access point I decided to put a PSK on the access point. Those are the only changes (other than the Pi itself) that differ between the two configurations.

Any ideas?

73, Jim, KD7F
KO4AZW
Posts: 7
Joined: Tue Feb 16, 2021 12:48 am

Re: YSFGateway Not Starting

Post by KO4AZW »

Apply Changes never helped in my case. Boots, reboots, adding or removing modes, etc. Only removing the two "M1ABC" references and replacing them with my own callsign.

Edit: I also did a full format of the microSD, new flash (basically two fresh installs,) and Configuration entry before discovering the "M1ABC" prefix in the entry described earlier.
KD7F
Posts: 10
Joined: Sat Feb 13, 2021 10:06 pm

Re: YSFGateway Not Starting

Post by KD7F »

Are you referring to settings on the Expert YSF GW page? I just checked and in both the General and APRS blocks my call is there since I set it on the Configuration page. Had you done that?

Just to add confusion...When I turned on the hotspot this morning I expected I would have to go and start the YSFGateway service as I had to every time I power cycled yesterday...But nope, it started just fine. I guess whatever problem I am experiencing is intermittent or dependent on some timing issue, possibly between threads where some variable isn't properly mutex protected. I am trying a reboot now to see if it comes up with the service running again...Nope after the reboot the YSFGateway service is NOT running. At least that is consistent. The service started after an "Apply Changes" button press on the configuration page as it had yesterday.

EDIT: I just did a full power down power cycle after shutting down with the dashboard Power Shutdown command. When I brought the hotspot back up the YSFGateway service was NOT running again. I think at least in my case, it is a rare occasion that the service will start on power up or reboot. I just happened to hit one of those occasions on the first power up this morning.

73, Jim KD7F
User avatar
WA6NDR
Posts: 1
Joined: Tue Feb 16, 2021 1:08 am
Location: Spokane, WA USA
Contact:

Re: YSFGateway Not Starting

Post by WA6NDR »

I bought my first hotspot, an AURSINC MMDVM Hotspot (https://www.amazon.com/dp/B088PPDRT7) on Amazon a few weeks ago. It arrived with old Pi-Star 3.4.17 / Dashboard 20190119. I did the usual configuration for YSF only, tested it on the air, and had a successful QSO! I upgraded to Pi-Star v4.1.4 / Dashboard 20210212 and got "YSF Network Service Not Started". I then wasted about 12 hours on web searches, reading, re-flashing various card sizes and types, configuration changes, Apply Changes, re-boots... I finally found others in the Facebook support group that had similar problems since v4.1.4 and had success with what worked today for me too -- I went back to Pi-Star v4.1.2 and everything works fine. I now plan to play with the working hotspot awhile, then after backing up everything trying to "upgrade" again.

[EDIT: A few hours later I tried using Pi-Star, Configuration, Update twice (4.1.2 -> 4.1.3 -> 4.1.4) so now have "Pi-Star:4.1.4 / Dashboard 20210212" and MMDVM firmware "HS_Hat:v1.5.2" with YSF working well. This is the same set of versions and (I believe) they are configured the same way as what gave all my earlier problems. This idea of going back to 4.1.2 and then forward to 4.1.4 is the same workaround that worked for at least two others in the Facebook support group.]
Last edited by WA6NDR on Thu Feb 18, 2021 10:41 pm, edited 1 time in total.
KO4AZW
Posts: 7
Joined: Tue Feb 16, 2021 12:48 am

Re: YSFGateway Not Starting

Post by KO4AZW »

KD7F wrote: Thu Feb 18, 2021 5:41 pm Are you referring to settings on the Expert YSF GW page? I just checked and in both the General and APRS blocks my call is there since I set it on the Configuration page. Had you done that?
Yes sir, exactly, but in my case, even though my callsign was on the Configuration page, the M1ABC callsign remained on the APRS block and apparently never updated itself. The manual correction on the YSF GW page, followed by an Apply then started the service, and has done so ever since, including reboots and cold starts from a system shutdown

Edit: Just confirmed... Pi-Star:4.1.4 / Dashboard: 20210212
User avatar
G8SEZ
Posts: 431
Joined: Fri Apr 13, 2018 8:26 pm

Re: YSFGateway Not Starting

Post by G8SEZ »

There is clearly at least one wrinkle in this code, but triggering it seems to be down to specific setups and making a change or changes in a specific way.

If it's working now then with luck that particular code path will never be used again, or at least I hope not.
--

Brian G8SEZ
KO4AZW
Posts: 7
Joined: Tue Feb 16, 2021 12:48 am

Re: YSFGateway Not Starting

Post by KO4AZW »

See my other topic in this forum. I don't know squat! I'm learning as I go...

I have read differing opinions on how to go about making changes; some say Apply Changes after each block, while others say Apply Changes by page. I thought I made changes by block, applying, then waiting for a new start-up. I can't provide an explanation for why my callsign was written on the first page, but never made it to the YSF GW page. I would assert that I applied several changes, restarts and reboots before noticing and then editing the YSF GW block, but who knows...

All I do know is that after making the change, and restarting, the Service appeared Green, and has been rock solid ever since.

I wouldn't blame anyone but myself for doing something wonky; Did I mention my other Topic ;)
KD7F
Posts: 10
Joined: Sat Feb 13, 2021 10:06 pm

Re: YSFGateway Not Starting

Post by KD7F »

I went back and re-imaged my uSD card with the 4.1.4 pi-star image and after configuration on a Pi 3B+ I saw the problem where the YSFGateway service would not start. As others have mentioned, imaging with 4.1.2 and then upgrading to 4.1.3 and 4.1.4 "solves" this problem and it worked for me too. I do notice however that the OS Kernel is different after this upgrade path than it was when going straight to the 4.1.4 image. The OS was loaded with the 4.1.2 image and the 4.1.4 image has a later Kernel version. The Kernel on the Pi3B+ after the upgrade path is showing 4.19.97-v7+. This would tend to indicate that something in the 4.1.4 pi-star version operating under the latest OS version is causing this behavior.

This is odd because the first time I imaged with 4.1.4 and set up this same hardware I had a slightly different problem. In that case the YSFGateway service wouldn't start on power up or reboot but I could go to configuration and hit an Apply Changes button and that would end up starting the YSFGateway service every time.

This is a bit frustrating... If anyone has any ideas of what I might do to shed more light on what might be causing this behavior please let me know. I have some new uSD cards being delivered today and I plan to image one of those with 4.1.4 and see if the behavior is any different...just to rule out potential data corruption on the uSD card I have been using.

73, Jim
Post Reply