BER and P25 Audio

Help with P25 issues
Post Reply
vk2faeu
Posts: 4
Joined: Fri Apr 24, 2020 2:06 am

BER and P25 Audio

Post by vk2faeu » Mon Sep 07, 2020 3:41 am

Hi all,

I've been attempting to dial in my offset for some time with my MMDVM hat when used with P25 (all motorola gear - XTS3000, XTL5000, XTL2500), and for the most part, my BER stays below 0.3%.

On most of my transmissions though (both to others via the internet, and via the parrot (TG10), I can hear pops, squeaks, qwacks etc on mostly every over.

Taking a look at my BER using the MMDVMCal tool, every now and then I see my BER jump above 10. Here's a copy from a recent test:

P25 LDU1 audio FEC BER % (errs): 0.243% (3/1233)
P25 LDU2 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU1 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU2 audio FEC BER % (errs): 0.162% (2/1233)
P25 LDU1 audio FEC BER % (errs): 0.487% (6/1233)
P25 LDU2 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU1 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU2 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU1 audio FEC BER % (errs): 0.487% (6/1233)
P25 LDU2 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU1 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU2 audio FEC BER % (errs): 0.811% (10/1233)
P25 LDU1 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU2 audio FEC BER % (errs): 0.406% (5/1233)
P25 LDU1 audio FEC BER % (errs): 0.487% (6/1233)
P25 LDU2 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU1 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU2 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU1 audio FEC BER % (errs): 0.162% (2/1233)
P25 LDU2 audio FEC BER % (errs): 0.162% (2/1233)
P25 LDU1 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU2 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU1 audio FEC BER % (errs): 0.730% (9/1233)
P25 LDU2 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU1 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU2 audio FEC BER % (errs): 0.730% (9/1233)
P25 LDU1 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU2 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU1 audio FEC BER % (errs): 0.811% (10/1233)
P25 LDU2 audio FEC BER % (errs): 0.243% (3/1233)
P25 LDU1 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU2 audio FEC BER % (errs): 0.973% (12/1233)
P25 LDU1 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU2 audio FEC BER % (errs): 0.162% (2/1233)
P25 LDU1 audio FEC BER % (errs): 0.000% (0/1233)
P25 LDU2 audio FEC BER % (errs): 0.324% (4/1233)
P25 LDU1 audio FEC BER % (errs): 0.162% (2/1233)
P25 LDU2 audio FEC BER % (errs): 0.081% (1/1233)
P25 LDU1 audio FEC BER % (errs): 0.000% (0/1233)
P25 TDU received, total frames: 124, bits: 152892, errors: 339, BER: 0.2217%

My question is: Is this expected on P25 or is there something wrong?

I've adjusted my offset to the point where my BER averages about 0.15XX%

Edit:
Pi-Star:4.1.2
Raspberry Pi Zero W (connected via ethernet using a mini usb to ethernet adapter)
STM32-DVM / MMDVM_HS - Raspberry Pi Hat (GPIO)
Connected to Cable internet (50 down/20 up)

Post Reply