P25 No Receive Decode Issue

Help with P25 issues
Post Reply
N8JDM
Posts: 17
Joined: Tue Jan 22, 2019 1:05 am

P25 No Receive Decode Issue

Post by N8JDM »

Hello, looking for some P25 help or wisdom. I'm working with a friend on a series of multi-mode digital repeaters and we're having an identical problem with all of them receiving/decoding P25. All three repeaters (full duplex) are running Pi-Star on a Raspberry Pi3 with a STM32-DVM "Pi-Hat" board from repeater-builder.com. The board is running the latest MMDVM firmware available for the board (FW v20180723 per the Pi-Star dashboard).

The setup works perfectly for D-Star, DMR, and YSF. However there is no success on P25. Whenever the P25 signal is received, the board indicator shows that the squelch is open but the "P25" light to indicate successful P25 decode never lights up. The same thing is experienced on three different systems (all with different RX radios). I don't see anything in any log on the unit that there is a failed decode or anything remotely wrong when the P25 signal is present. I'm not sure how to debug this facet further? Is there some sort of tunable needed to adjust for P25 for a successful decode - perhaps some sort of audio strength adjustment?

Any hints or ideas would be appreciated. Thanks.
N8JDM
Posts: 17
Joined: Tue Jan 22, 2019 1:05 am

Re: P25 No Receive Decode Issue

Post by N8JDM »

VK4TUX, thanks for the reply. I was looking at P25TXLevel but that seems to be on outbound transmissions to client radios not MMDVM receiving P25. Am I misunderstanding what that item does? Is there a corresponding P25RXLevel?
N8JDM
Posts: 17
Joined: Tue Jan 22, 2019 1:05 am

Re: P25 No Receive Decode Issue

Post by N8JDM »

VK4TUX wrote: Wed Jan 23, 2019 10:57 pm In that case I suggest that you do not have your DMR id programmed correctly in the ASTRO id field in each radio.
I assume you have the repeater nodes set public access in pstar config.

Your p25 radio tx will be blocked by the mmdvm until it see's the correct id.
This was exactly it. We weren't expecting to need an ID for local/Parrot. Once the ASTRO ID was filled in and a little tweaking of the P25TXLevel, everything was working with local/Parrot. I would have thought that the P25 decode would start and maybe get an error rather than not decode at all. Bad assumption there. Thanks for your wisdom on this!
VK4TUX wrote: Wed Jan 23, 2019 10:57 pm What P25 radio's do you use ? I have all XTL / XTS and APX types to provide programming advice re the id ?
I don't know what the radio is precisely because it's a friend's who does commercial radio professionally and he's trying from his house to my repeater. Would put safe money on it being a Motorola of some type.
ZS5BG
Posts: 1
Joined: Sun Aug 30, 2020 4:19 pm

Re: P25 No Receive Decode Issue

Post by ZS5BG »

Would the mmdvm decode any NAC and ID if the P25 "lookup ID setting" is disabled?
vk3kbc
Posts: 1
Joined: Tue Mar 16, 2021 12:17 pm

Re: P25 No Receive Decode Issue

Post by vk3kbc »

Hi All,

I had exactly the same problem. I could use the hotspot with DSTAR and DMR, but the hotspot would not decode P25.

Apparently you do need to program the transceiver’s ASTRO ID field with your DMR ID for the hotspot to decode P25 transmissions. I had my ACMA License Number as the ASTRO ID programmed into my XTS3000 (as was recommended years ago – before hotspots were around) and that obviously didn’t match the DMR ID programmed into the hotspot.

The trap for the uninitiated is that there is no decode at all and no error reported if you have this mismatch. I would have thought that it would at least decode but report an error, but that’s not the case. So the result is that it appears that the hotspot isn’t working, when actually it is.

The workaround if you don’t have the ID’s matched is that you need to set ‘OverrideUIDCheck’ to ‘1’ on the hotspot. The hotspot then works with P25, but the hotspot doesn’t display your callsign (obviously) on the Hotspot OLED or the pi-star Dashboard. When I reprogrammed my XTS3000 ASTRO ID with my DMR ID and set the ‘OverrideUIDCheck’ parameter on the hotspot back to ‘0’, it all worked as expected, displaying my callsign as well.
Post Reply