No idle display on ZumSpot in YSF2P25 X-mode

Help with P25 issues
Post Reply
KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Fri Oct 18, 2019 6:50 pm

I have a PiStar ZumSpot set up for YSF2P25 mode, running PiStar v4.10 RC3 and I don't see anything on the display in Idle mode. It says Fusion when a call comes in or when I make a call out and it seems to be working but I miss it saying MMDVM when it is in idle. Any ideas?

Also, I seem to remember when I set it up before a while back with 3.4.17 that it did show the Idle message and that it displayed P25 on received calls.

Any help appreciated.

Dave KC6N

KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Fri Oct 18, 2019 10:26 pm

I am not sure this is unique to P25, actually. I will re-post in General when I run some more tests.

KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Fri Oct 18, 2019 10:50 pm

I think that I have solved it. It looks like the last line in the OLED section (Expert mode, MMDVM Host) needs to be set to "1". Maybe this is something new, I don't know maybe some how the bit got flipped. Anyway, things look normal now. If is see anything else strange, I'll post in general.

Dave

KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Fri Oct 18, 2019 10:57 pm

Yep, this field is definitely new. Not sure when it appeared.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KE0FHS » Sat Oct 19, 2019 2:40 pm

KC6N wrote:
Fri Oct 18, 2019 10:57 pm
Yep, this field is definitely new. Not sure when it appeared.
Are you talking about the "Cast" field? That's been there for awhile, though I've never known what it is for.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Sun Oct 20, 2019 2:43 am

Toshen

I was talking about the LogoScreenSaver one at the bottom. I had not seen it before and in the process of making some changes to my settings it got set to "0" which made the little 1,6" OLED go blank.

I am also curious what "Cast" does. No effect seen for me as well. Similarly for "Scroll". Perhaps these work for other versions of OLED displays. Also does "Rotate" only flip 180? Setting the field to "1" flips 180 but it would thing there might be a setting for 90 degrees as well. Have you found one?

Thanks, Dave KC6N

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KE0FHS » Sun Oct 20, 2019 1:47 pm

Hi Dave,

Interesting. I'm on 4.1.0-RC6 20191016, and don't see that option, but I'm using a Nextion display. I wonder if you have to enable OLED before that option shows up?

UPDATE: Yep, that's what it is, I changed the settings on the Configuration page to OLED and that triggered the new setting showing up.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KE0FHS » Sun Oct 20, 2019 2:19 pm

KC6N wrote:
Sun Oct 20, 2019 2:43 am
I am also curious what "Cast" does. No effect seen for me as well. Similarly for "Scroll". Perhaps these work for other versions of OLED displays. Also does "Rotate" only flip 180? Setting the field to "1" flips 180 but it would thing there might be a setting for 90 degrees as well. Have you found one?
Here's what I've learned over time:
Change rotation: Rotate = 0 or 1. No other settings.
Invert background: 0 = white text on black background or 1 = black text on white.
Scroll (mode label when active): 1 = Yes or 0 = No. I used to have an OLED display and it did scroll; not sure why your display doesn't.
Change brightness: 10 = bright or 0 = less bright (effect varies by modem board).
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KC6N
Posts: 20
Joined: Mon May 07, 2018 5:07 am

Re: No idle display on ZumSpot in YSF2P25 X-mode

Post by KC6N » Sun Oct 20, 2019 7:51 pm

Toshen --

Thanks, pretty much what I have seen as well. TNX for confirming.

Dave

Post Reply