Pi-star Dashboard P25 service is not running

Help with P25 issues
f1rmb
Posts: 26
Joined: Thu Feb 21, 2019 12:12 pm

Re: Pi-star Dashboard P25 service is not running

Post by f1rmb »

Hi,

About the Service not Started problem, the getActualLink() function has a bug and need to be fixed for NXDN and P25:

Code: Select all

diff --git a/mmdvmhost/functions.php b/mmdvmhost/functions.php
index e43bfdbd7c65..cff0e8e5b604 100755
--- a/mmdvmhost/functions.php
+++ b/mmdvmhost/functions.php
@@ -996,6 +996,7 @@ function getActualLink($logLines, $mode) {
                   return "Not Linked";
                }
             }
+            return "Not Linked";
         } else {
             return "Service Not Started";
         }
@@ -1042,6 +1043,7 @@ function getActualLink($logLines, $mode) {
                   return "Not Linked";
                }
            }
+            return "Not Linked";
        } else {
             return "Service Not Started";
         }


Cheers.
---
Daniel
User avatar
MW0MWZ
Site Admin
Posts: 1332
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Pi-star Dashboard P25 service is not running

Post by MW0MWZ »

f1rmb wrote: Wed Feb 10, 2021 4:54 pm Hi,

About the Service not Started problem, the getActualLink() function has a bug and need to be fixed for NXDN and P25:

Code: Select all

diff --git a/mmdvmhost/functions.php b/mmdvmhost/functions.php
index e43bfdbd7c65..cff0e8e5b604 100755
--- a/mmdvmhost/functions.php
+++ b/mmdvmhost/functions.php
@@ -996,6 +996,7 @@ function getActualLink($logLines, $mode) {
                   return "Not Linked";
                }
             }
+            return "Not Linked";
         } else {
             return "Service Not Started";
         }
@@ -1042,6 +1043,7 @@ function getActualLink($logLines, $mode) {
                   return "Not Linked";
                }
            }
+            return "Not Linked";
        } else {
             return "Service Not Started";
         }


Cheers.
---
Daniel
Thank you very much - patch applied.
Andy

73 de MW0MWZ
http://pistar.uk
AF5XP
Posts: 4
Joined: Sun Apr 15, 2018 4:39 am

Re: Pi-star Dashboard P25 service is not running

Post by AF5XP »

I HAVE NOTICED THE SAME THING AND IT WONT EVEN KEY OR CONNECT. I SWITCHED BACK TO 4.1.3 AND EVERYTHING STARTED TO WORK CORRECTLY AGAIN. SO I GUESS ILL STAY ON THAT VERSION, TILL THEY CAN FIX THE BUGS IN 4.1.4
f1rmb
Posts: 26
Joined: Thu Feb 21, 2019 12:12 pm

Re: Pi-star Dashboard P25 service is not running

Post by f1rmb »

Hi,
AF5XP wrote: Fri Feb 12, 2021 8:54 pm I HAVE NOTICED THE SAME THING AND IT WONT EVEN KEY OR CONNECT. I SWITCHED BACK TO 4.1.3 AND EVERYTHING STARTED TO WORK CORRECTLY AGAIN. SO I GUESS ILL STAY ON THAT VERSION, TILL THEY CAN FIX THE BUGS IN 4.1.4
It's fixed in the current version (as Andy told).

I think you need to fix your capslock key :-D


Cheers.
---
Daniel
AF5XP
Posts: 4
Joined: Sun Apr 15, 2018 4:39 am

Re: Pi-star Dashboard P25 service is not running

Post by AF5XP »

f1rmb wrote: Fri Feb 12, 2021 8:57 pm Hi,
AF5XP wrote: Fri Feb 12, 2021 8:54 pm I HAVE NOTICED THE SAME THING AND IT WONT EVEN KEY OR CONNECT. I SWITCHED BACK TO 4.1.3 AND EVERYTHING STARTED TO WORK CORRECTLY AGAIN. SO I GUESS ILL STAY ON THAT VERSION, TILL THEY CAN FIX THE BUGS IN 4.1.4
It's fixed in the current version (as Andy told).

I think you need to fix your capslock key :-D


Cheers.
---
Daniel
Well I updated to 4.1.4 on Thursday and had the problem, so I down graded back to 4.1.3 Unless he fixed it today then its still has bugs.
vk3jma
Posts: 6
Joined: Fri Aug 10, 2018 11:23 am

Re: Pi-star Dashboard P25 service is not running

Post by vk3jma »

3 x Zimmerman boards, 2 running simplex, 1 running duplex.

1 x simplex working on P25.

1 x simplex and 1 x repeater P25 RED not working.

All running 4.1.4 20210212 Dashboard.

Done UPDATE several times with a "apply changes" in config menu.

Still P25 no go??

Thanks Andy for your efforts.

Mark
User avatar
VK7HSE
Posts: 222
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Pi-star Dashboard P25 service is not running

Post by VK7HSE »

vk3jma wrote:3 x Zimmerman boards, 2 running simplex, 1 running duplex.

1 x simplex working on P25.

1 x simplex and 1 x repeater P25 RED not working.

All running 4.1.4 20210212 Dashboard.

Done UPDATE several times with a "apply changes" in config menu.

Still P25 no go??

Thanks Andy for your efforts.

Mark
Hey Mark,

Are any of those using a nextion display with the nextion driver installed to capture the extra fields that are available in some templates?

Now I might be barking up the wrong tree, but all 6 of mine were still on the nextion driver 1.18 and I've just gone through them and updated them to 1.19 This may not be related but with the combination of what I emailed you the other day and what I've just done, I think I'm back to normal operation (or not as it's too early to tell)

Cheers

Sent from my Pixel 4 XL using Tapatalk

vk3jma
Posts: 6
Joined: Fri Aug 10, 2018 11:23 am

Re: Pi-star Dashboard P25 service is not running

Post by vk3jma »

Mine all have the nextion displays. not sure how to determine version number or how to upgrade?

There could be different model nextions involved as well.

Just looked and still the same, 2 x not working 1 x working as previous post.

Regards

Mark
KE7FNS
Pi-Star Team
Posts: 1794
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi-star Dashboard P25 service is not running

Post by KE7FNS »

vk3jma wrote: Fri Feb 19, 2021 7:07 am Mine all have the nextion displays. not sure how to determine version number or how to upgrade?
Run the Nextion Driver Installer script again, it will detect it and update it if it is needed. It will not be in the /tmp directory so you'll have to redownload it again.
vk3jma wrote: Fri Feb 19, 2021 7:07 am There could be different model nextions involved as well.
Nextion models do not matter, they all use the same basic serial communications.

I seriously doubt it is related to the Nextion Driver version, and simply a coincidence. Nothing has changed recently with the Nextion Driver.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
W2VS
Posts: 12
Joined: Tue Feb 16, 2021 10:47 pm

Re: Pi-star Dashboard P25 service is not running

Post by W2VS »

Applying the P25 services patch is probably way above my pay grade but having said that is there a place where I can be pointed that tells me how to do it?
I am getting the error message that the P25 service isn’t running so I presume that is what I need to do.
I saw the posts showing the patch but I really couldn’t follow how to do it.
Thanks!
Dave W2VS
Post Reply