Pi-star Dashboard P25 service is not running

Help with P25 issues
W2VS
Posts: 12
Joined: Tue Feb 16, 2021 10:47 pm

Re: Pi-star Dashboard P25 service is not running

Post by W2VS »

OK I did an update thru PuTTY app and that looks like it fixed it? I now have a Green box under “Network Status” for P25.
vk3jma
Posts: 6
Joined: Fri Aug 10, 2018 11:23 am

Re: Pi-star Dashboard P25 service is not running

Post by vk3jma »

Hi All,

Still having troubles.

Did the putty upgrade and a reboot yet it still will not start the P25 service.

Happening to 2 out of 3 of my hotspots.


Regards

Mark
vk3jma
Posts: 6
Joined: Fri Aug 10, 2018 11:23 am

Re: Pi-star Dashboard P25 service is not running

Post by vk3jma »

Hi there,

well, still not fixed.

I did a fresh install to the Pi but I am still having "service not started" for P25.

DMR and NXDN are fine.

Anyone have any ideas?

Thanks

Mark
vk3jma
Posts: 6
Joined: Fri Aug 10, 2018 11:23 am

Re: Pi-star Dashboard P25 service is not running

Post by vk3jma »

***** Solved *******

I run multiple Pistars on the one network, years ago, with the great assistance of Andy, I found that I could not have all the pi's running P25 at the same time as they were all using the same port. I believe Andy did some changes and randomized the P25 network port on startup which solved my issue back then.

The solution then was to Hash out #42010 the P25 network entry in /etc/p25gateway and allow the network/system to dynamically allocate a port, or so that is how I understand it??

[General]
Callsign=VK3JMA
RptAddress=127.0.0.1
RptPort=32010
LocalPort=42020
Daemon=1

[Id Lookup]
Name=/usr/local/etc/DMRIds.dat
Time=24

[Log]
FilePath=/var/log/pi-star
FileRoot=P25Gateway
DisplayLevel=1
FileLevel=1

[Network]
#Port=42010
HostsFile1=/usr/local/etc/P25Hosts.txt
HostsFile2=/usr/local/etc/P25HostsLocal.txt
ReloadTime=60
ParrotAddress=127.0.0.1
ParrotPort=42011
#Startup=
Debug=0
RFHangTime=0
NetHangTime=0
P252DMRAddress=127.0.0.1
P252DMRPort=42012
Static=10700

[Voice]
Enabled=1
Language=en_GB
Directory=/usr/local/etc/P25_Audio

[Remote Commands]
Enable=1
Port=6074


Now years later, something may have changed??

2 out of the 3 hotspots I was running would not start the P25 network after upgrading to 4.1.4.

I looked at each /etc/p25gateway file in SSH and found that the one that was working did not have the network port hashed out and the others did.

I edited the files on the 2 "not working" hotspots, removing the hash in front of the port number and they came straight up on P25 network.

So, not sure what has changed but I am now running 3 x hotspots with p25 on the one network al using 42010 as the network port.

Its working, now I will leave it alone.

Mark
Post Reply