Unable to Switch Back to 'rpi-ro'

General support for the Pi-Star System
KE7FNS
Posts: 421
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Sat Oct 12, 2019 6:51 pm

Dang, thats an army of RPi's Toshen, whats next? Are you going to use the old ones to build a RPi cluster supercomputer?

I find the 3 B+'s are plenty fast but yeah a RPi Zero is a freaking slug, I don't know how people can put up with still using the original RPi.

Hey, since you seem to have better luck getting them stuck in RW mode, pm me some way to get ahold of you and I'll send you my notes and you can figure out which services it is that are causing the lock.
All views, comments, posts and opinions shared are entirely my own.

User avatar
KE0FHS
Posts: 1072
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Sat Oct 12, 2019 7:16 pm

Ha-ha, that's a strange example of "better luck"! ;)

My callsign at gmail.com works.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KE7FNS
Posts: 421
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Sun Oct 13, 2019 9:22 pm

Well, I have found a different way to get the system back into RO mode, I'm not sure how "safe" it is so I'd rather not make it public right this second, but if Andy or some other person with years of Linux experience would PM me we can discuss it in private and see if it is a viable option to solve the ongoing stuck in RW issue.
All views, comments, posts and opinions shared are entirely my own.

W2SJW
Posts: 17
Joined: Fri May 25, 2018 12:12 am

Re: Unable to Switch Back to 'rpi-ro'

Post by W2SJW » Fri Oct 18, 2019 2:11 pm

Just an FYI - I ran a pistar-update on both my DMR ZUM and Fusion Jumbo today after reading about a potential kernel glitch from a friend & both units came back up 'ro' after a safe reboot.

Maybe it was something specific to Buster, and not Andy's software?

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Fri Oct 18, 2019 4:55 pm

W2SJW wrote:Just an FYI - I ran a pistar-update on both my DMR ZUM and Fusion Jumbo today after reading about a potential kernel glitch from a friend & both units came back up 'ro' after a safe reboot.

Maybe it was something specific to Buster, and not Andy's software?
I updated all 5 of my hotspots. They went into ro. Played around with them some...doing updates, going into rw mode. All ended up back on ro. Maybe the mystery is solved.

Sent from my SM-A102U using Tapatalk


KE7FNS
Posts: 421
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Fri Oct 18, 2019 8:36 pm

W2SJW wrote:
Fri Oct 18, 2019 2:11 pm
Just an FYI - I ran a pistar-update on both my DMR ZUM and Fusion Jumbo today after reading about a potential kernel glitch from a friend & both units came back up 'ro' after a safe reboot.

Maybe it was something specific to Buster, and not Andy's software?
Just to clarify the issue being discussed is after "sudo pistar-update" was run and it remaining in RW before you reboot it.
All views, comments, posts and opinions shared are entirely my own.

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Sat Oct 19, 2019 1:10 am

Yeah. It goes back to ro after an update.

Sent from my SM-A102U using Tapatalk


User avatar
KE0FHS
Posts: 1072
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Sat Oct 19, 2019 2:10 pm

KD8DVR wrote:
Sat Oct 19, 2019 1:10 am
Yeah. It goes back to ro after an update.
This bug has always been a bit random for me, going to rw sometimes, but not always; so while it's great to see some people having success seeing it go back to ro after an update, I'll be waiting a week or two before I start thinking it's really solved.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Sat Oct 19, 2019 2:14 pm

KE0FHS wrote:
Sat Oct 19, 2019 2:10 pm
KD8DVR wrote:
Sat Oct 19, 2019 1:10 am
Yeah. It goes back to ro after an update.
This bug has always been a bit random for me, going to rw sometimes, but not always; so while it's great to see some people having success seeing it go back to ro after an update, I'll be waiting a week or two before I start thinking it's really solved.
Yeah. I can understand being cautious.

AF6VN
Posts: 273
Joined: Fri Jul 20, 2018 1:15 am

Re: Unable to Switch Back to 'rpi-ro'

Post by AF6VN » Sat Oct 19, 2019 4:30 pm

Well - to add to the situation... R-Pi 3B Pi-Star 3.4.17

After an uptime of over 16 days, I just ran the sequence over in the WiFi category explaining how to set the locale (it had been using en-GB, I switched it to en-US -- and I should state that just using dpkg-reconfigure was not sufficient; had to use raspi-config to ensure the environment was set)... And my unit is now stuck in the RW stage, requiring a reboot to clear.

I did run an lsof, but I'm not sure what I should be looking for in that long listing.

--
AF6VN
Dennis L Bieber

Post Reply