Little snag in 4.1.6 beta

Help with the Orange Pi Zero
Post Reply
M0TQM
Posts: 5
Joined: Tue Mar 10, 2020 7:39 pm

Little snag in 4.1.6 beta

Post by M0TQM »

Hi all

I was forced to install beta today because BM API stopped working on the 3.x version.

Here are my observations and solutions:
- After install the wifi used for configuration does not come up - connect ethernet cable and you will access it that way
- After configuring wifi network and issuing connect, pi-star does not acquire IP address, this is due to error in
/etc/default/interfaces
file, which says

Code: Select all

allow-hotplug wlan0                                                             
iface wlan0 inet static      
If you change 'static' to 'dhcp' and reboot, it will work as expected. No more ethernet cable needed.

Other than that, 4.1.6 seems to work perfectly fine. I would say the OrangePi feels snappier than before, so all in all great outcome.

Thank you,
Vy 73!
Tom M0TQM
M1DNS
Pi-Star Team
Posts: 1158
Joined: Thu Apr 05, 2018 5:30 am

Re: Little snag in 4.1.6 beta

Post by M1DNS »

M0TQM wrote:Hi all

I was forced to install beta today because BM API stopped working on the 3.x version.
...

Tom M0TQM

4.1.6 is not a beta release. its the current release.


3.4.** is a diminished release, current as of 2019. So yes, It wont cater to modern changes being made by the networks or in other organisations outside of pistar.


As to your mentioned issue. that all gets changed if you setup wifi either via Pistar AP or Wifi Builder found on the pistar website and is defaulted that way, i believe specifically for use with Pistar AP.

Wifi builder, creates its own wpa supplicants file which overwrites the current setup on the pi. once its dragged onto the sd cards boot partition. so the above mentioned shouldnt be an issues for a user either.

But appreciate the heads up. sometimes these things get missed, sometimes its by intention.

Ill pass what youve written above to Andy just to be sure. In case ive got it wrong myself.


Sent via smoke signals from my SM-G935F M1DNS (Admin)


EDIT: I guess I completly missed the reference to you using an orangepi board, so discount all I've replied above.







Andrew M1DNS.
Pi-star Admin Team.
Post Reply