Dual Hat / FT-5DR / FTM-400XDR issue

MMDVM_HS Hat hardware
KD9TGR
Posts: 12
Joined: Tue Nov 30, 2021 5:01 am

Re: Dual Hat / FT-5DR / FTM-400XDR issue

Post by KD9TGR »

Today I updated my pi-star firmware. Here is the latest output from find modem.

Detected MMDVM_HS Port: /dev/ttyAMA0 (GPIO) Baud: 115200 Protocol: V1
Modem Data: MMDVM_HS_Dual_Hat-v1.5.2 20201108 14.7456MHz dual ADF7021 FW by CA6JAU GitID #89daa20FF56066C5548826687214627

I also changed both antennas to a bit better antennas.

Next, I did try to run "sudo pistar-mmdvmcal"
Initial configuration
e - 43430000
z - 10
J - to listen to both radios Tx

////////////////////////////////////
Best BER for FT-5DR
YSF voice header received

TX frequency: 434301090
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.247% (1/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.494% (2/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)

TX Level: 50.0%, Frequency Offset: 1090, RF Level: 100.0%

////////////////////////////////////
Best BER for FTM-400XDR
TX frequency: 434299950

YSF voice header received
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.247% (1/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.247% (1/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.000% (0/405)

TX Level: 50.0%, Frequency Offset: -50, RF Level: 100.0%

So, both radios can activate pi-star.
Below is the shared frequency @ step 25Hz that both radios do activate

TX frequency: 434300500

/////////////////// FT-FTM-400XDR
YSF voice header received
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.988% (4/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.247% (1/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.222% (9/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.975% (8/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.235% (5/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.988% (4/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.469% (10/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.728% (7/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.494% (2/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.741% (3/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 0.988% (4/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.963% (12/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.481% (6/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.235% (5/405)
YSF voice end received, total frames: 14, bits: 5670, errors: 80, BER: 1.41093%

/////////////////// FT-5DR
YSF voice header received
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.481% (6/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 3.210% (13/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.716% (11/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 3.457% (14/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.975% (8/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.481% (6/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.975% (8/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.975% (8/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.728% (7/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 3.457% (14/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 1.975% (8/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.716% (11/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.222% (9/405)
YSF, V/D Mode 2, Repetition FEC BER % (errs): 2.469% (10/405)
YSF voice end received, total frames: 14, bits: 5670, errors: 133, BER: 2.34568

I can not get any better. are there any other settings I can try to play with to get lower BER with both radios?

Thank you
KJ7WFB
Posts: 3
Joined: Tue Jun 15, 2021 10:10 am

Tuning a duplex MMDVM

Post by KJ7WFB »

I have a duplex MMDVM hat for a Raspberry Pi -- STM32-DVM/MMDVM_HS-Raspberry.pi Hat(GPIO). The Pi runs the latest version of Pi-Star and I have updated the firmware on the MMDVM hat. It is configured to run in duplex on two frequencies; 439.620 and 434.620, and to connect with Yaesu System Fusion.

It works and I can connect to YSF rooms, but there is strangeness in the BER reports I see. I get reports of less than 1% BER when I am speaking and transmitting manually. But, when the radio (Yaesu FT5D) sends other data to the MMDVM like a connection request or a request to link or unlink a room, the results are not reliable and the reported BER is always 77% -- very high.

I have tuned the MMDVM receive frequency using the pistar-mmdvmcal tool and the resulting BER is less than 1%. I looked at the MMDVM transmit signal with an SDR on my PC and the frequency seems OK, but the scale on the SDR does not offer high precision. I don't know any other way to check the frequency of the MMDVM transmit side, and in the end I set its offset to a value close to the one I used on the receive side.

When I transmit voice on YSF the BER is under 1% but the control transmissions from my radio continue to work unreliably and show a BER of 77% no matter what I do to the RCV and XMT offsets in Pi-Star. Can anyone here tell me (1) how to measure and calibrate the XMIT frequency from the MMDVM hat and (2) what is going on with the control messages from my FT-5D?
KD9TGR
Posts: 12
Joined: Tue Nov 30, 2021 5:01 am

Re: Dual Hat / FT-5DR / FTM-400XDR issue

Post by KD9TGR »

So I updated my MMDVM board with the latest dual hat firmware and also the entire system (rpi-rw, sudo apt update, sudo apt upgrade, rpi-ro)
Now, after pi-star reboot, I did check that my TX and RX offsets are set to zero.
Looks like my 400XDR is working very well now :) No firmware or configuration changes on my 400XDR since the initial report.

In the meantime, I did send my radio to Yaesu to get it checked. I was told that everything seems fine with the radio. I was told that
they know about pi-star issues. but I was told that it is not limited to just this model. It is a problem with other models as well. So it is hit or miss.
Since they do not support pi-start (as expected) there is a dead-end there. I specifically asked to check the radio if it is "dead on" with Tx frequency. I was told that it is within 5ppm as expected.

But, today I got the radio back 5DR and after reprogramming it 438.900/433.900/DN/Public
5DR is still not working. When I start Live logs and PTT on my radio. I see no activity.

Here is another twist. A friend of mine borrowed me his pi-star. It is running older pi-start and firmware. Maybe 2-3 years old? I can look up versions if someone needs them. So he also has 5DR and last weekend I did meet with him and he showed me his 5DR radio was working fine with this pi-star. I could not test it then since I was waiting for the radio.

So bottom line: I have two pi starts running different MMDVM hardware and software, two 5DR radios. My friends work and my does not.

I will try to meet with my other friend and try my 5DR with the open spot 2 unit and see if it works.
Any other ideas to try? Any developers here can assist me with diagnosing this issue?
Looks like there is STLink header on PCB right above the ST chip. I can set up some debugging? Any ideas?

Robert
KD9TGR
Posts: 12
Joined: Tue Nov 30, 2021 5:01 am

Re: Dual Hat / FT-5DR / FTM-400XDR issue

Post by KD9TGR »

Here is update. I noticed something odd. It looks like radio will start working with pistar “after some time”. Not sure if it is the radio or pi-star but after some worm up time it will start transmitting. I was at my ham friend other day and he also has 5DR. His works every time. We switched to parrot and started PTT both radios. At some point my started to work. It took about 10 min? But then 1 hr layer it stopped. Radio was checked by Yaesu support and I was told it is up to a spec.
I almost did try my friends openSpot2. And my 5DR worked every time. So not sure if this is still pi-star or my radio.
I was told that Yaesu support knows about this issue and it is not limited to this radio. I was not told why sine they do not support pi-star.

Anyone else had this strange behaviour?
I am thinking about selling this radio and go with different brand. Any suggestions?
Post Reply