Cannot Connect to Dashboard

General support for the Pi-Star System
Post Reply
KE8CLD
Posts: 4
Joined: Mon Apr 25, 2022 7:22 pm

Cannot Connect to Dashboard

Post by KE8CLD »

I'm new to this so I must put out this disclaimer. If it appears I don't know what I'm talking about, I probably don't. So I have a Nex Gen hotspot. It was set up prior to my receiving it about 3 years ago and worked perfectly. I have since changed internet providers and have flashed with the new information and was able to get it set up correctly at the command prompt. However, when I type in pi-star.local I am always sent to a search engine referring me to Pi-Star website. When I put in the Pi-star IP address I get a page telling me "This site cannot be reached." How can I get to the dashboard to set it up to use with my Yeasu FT2D? I have logged into my router and the Pi-Star is there. I have no idea how to get this to work. Would appreciate any help I can get. Please be patient as I am not computer literate. Thanks.
Rodger
Last edited by KE8CLD on Thu Apr 28, 2022 8:11 pm, edited 1 time in total.
AF6VN
Posts: 715
Joined: Fri Jul 20, 2018 1:15 am

Re: Cannot Connect to Dashboard

Post by AF6VN »

First step, in my mind, would be to use a CAT-5 (or higher) cable -- if possible (some systems don't have the RJ45 Ethernet jack) -- between the hot spot and your router (and I can't really look up what your have... "NEX-GEN" produces something like six different models). That is -- try to eliminate the WiFi linkage(s) in the system.

Second, log into the ROUTER and confirm IP assignment to the hotspot device, and then try connecting using that IP. I don't really understand what you mean by "WiFi account" -- WiFi access points have an SSID and a passcode... but that just allows clients to send traffic through the access point, it isn't used for getting to configuration/set-up services.

Reason for eliminating the WiFi paths -- some WiFi routers are configured to ONLY permit WiFi clients to connect out to the Internet, but block any connection between WiFi clients inside the local network (this is the type of system used by "public WiFi" to prevent one person snooping onto some other person's device). If you are forced to use WiFi paths, you will need to ensure your router allows client<>client connections in the LAN side. Also note: not all routers require the .local domain, they may respond to just pi-star as the host name (and that presumes the device is using pi-star as the host name -- I configured mine to identify the hardware http://pi-star-3b/ -- as, at the time, I was considering a second unit to allow non-competing D-STAR and DMR usage).

--
AF6VN
Dennis L Bieber
KE8CLD
Posts: 4
Joined: Mon Apr 25, 2022 7:22 pm

Re: Cannot Connect to Dashboard

Post by KE8CLD »

So, I did as you suggested. I used a Cat 6 patch cord and connected it between my router and the hot spot. I then logged into the router and confirmed the IP assignment to the hotspot device and tried connecting using that IP address. I still got the same result. "This site cannot be reached."
I have the Nex-Gen "Rugged Spot". Robert configured the hotspot for me before shipping and it worked as advertised, but now I can't get it to work. Not sure if i've given you enough/correct information for you to figure out what I'm doing wrong. I ran a Windows Network Diagnostics and it said "Your computer appears to be correctly configured but the device detected or resource (IP address) is not responding." Not sure what more I can tell you. Thanks for your help.

EDIT: I ran a health check on the router and this is what it found:

Hosts Conflicted IP Address
B8:27:EB:A9:77:B2 192.168.1.181
B8:27:EB:FC:22:E7

IP Addresses Conflicts Found

I checked and the IP address assigned while on the LAN is 192.168.1.180
AF6VN
Posts: 715
Joined: Fri Jul 20, 2018 1:15 am

Re: Cannot Connect to Dashboard

Post by AF6VN »

KE8CLD wrote: Thu Apr 28, 2022 7:04 pm So, I did as you suggested. I used a Cat 6 patch cord and connected it between my router and the hot spot. I then logged into the router and confirmed the IP assignment to the hotspot device and tried connecting using that IP address. I still got the same result. "This site cannot be reached."
My suspicion is still something router related -- possibly blocking any traffic from LAN node to LAN node. Do you have any other clients that you could attempt to connect to from the computer?
EDIT: I ran a health check on the router and this is what it found:

Code: Select all

Hosts                                             Conflicted IP Address
B8:27:EB:A9:77:B2                          192.168.1.181
B8:27:EB:FC:22:E7
Not quite sure how to interpret that. My best guess is that you have two devices on the network (the two MAC addresses on the left) both claiming to be using the same IP address. B8:27:EB:... tends to be the MAC range used by Raspberry-Pi systems. It IS vaguely possible that those are both the same unit if the cable AND WiFi are being detected (though mine does not show a WiFi connection to "microdiversity" which is on a CAT-5).

Do you have an ability to have the router "forget" all clients, then reconnect them one at a time.

Code: Select all

IPv4 Address / Name 	                        MAC Address 	   Status 	Allocation 	Action
192.168.1.68 / EPSONF4EF32 	                00:26:ab:f4:ef:32 	on 	DHCP Allocation 	
192.168.1.65 / DIRECTV-HR54-C94828D7 	18:16:c9:48:28:d9 	on 	DHCP Allocation 	
192.168.1.72 / android-f2715b5ffc0fee68 	58:b0:d4:3b:09:ee 	off 	DHCP Allocation 	
192.168.1.74 / unknown64c6670531d3 	64:c6:67:05:31:d3 	off 	DHCP Allocation 	
192.168.1.70 / Galaxy-S9 	                        8c:45:00:6d:1a:4c 	on 	DHCP Allocation 	
192.168.1.79 / pi-star-3b 	                        b8:27:eb:4b:0b:d5 	on 	DHCP Allocation 	
192.168.1.252 / microdiversity 	                b8:27:eb:ce:b1:eb 	on 	DHCP Allocation 	
192.168.1.66 / ElusiveUnicorn 	                b8:ca:3a:79:0c:36 	on 	DHCP Allocation 	
192.168.1.84 / HP7C548D 	                c4:65:16:7c:54:8d 	on
"microdiversity" is the name of an R-Pi I have running a web server.

Code: Select all

Help
Ethernet: Configure the transmission capabilities of each ethernet port. The default of auto adapts to the abilities of the client.

MDI-X: The Medium Dependent Interface Crossover allows networked devices to connect to each other. 
MDI-X seems to control my router's cable switch -- default is "auto" but it sounds like setting "off" would result in LAN<>LAN blocking. On the WiFi side, my router has two SSIDs; one is the "real" LAN access. The other is a "guest" WiFi -- meant to be handed out to visitors with a simpler passcode, and is configured to only pass to the Internet (can be configured for Internet&LAN).

If it isn't obvious -- I'm sort of free-associating at this point, looking for anything that might be on your router that could be checked.

--
AF6VN
Dennis L Bieber
KE8CLD
Posts: 4
Joined: Mon Apr 25, 2022 7:22 pm

Re: Cannot Connect to Dashboard

Post by KE8CLD »

Sorry, but now I'm getting in over my head. I pretty much don't understand most of what your asking me to do. I'm getting worn out trying to figure this out. Been at it for 5 straight days now. I appreciate all your help though. Thanks.
dh3ybe
Posts: 81
Joined: Sun Aug 26, 2018 9:02 pm
Location: Germany

Re: Cannot Connect to Dashboard

Post by dh3ybe »

Hello,

Only tot give others a hint, what the next steps would be now.

Thanks Dennis for his work.

It is an Router wlan or LAN problem, now. You have 2 network devices with the same local IP-Adresses., I would check now all my computers , where the listet MAC network Hardware Adresses do occur. Maybe at the hotspot with to wlan devices or wlan and lan combined or other computers, where one receives the network in address dhcp Server and another computer, which was given this problem ip-address manually not via dhcp from the router.

Rodger, ask an OM in your neighbourship with wlan experience if he would,may help you.


Best Regards
Kai
dh3ybe
KE8CLD
Posts: 4
Joined: Mon Apr 25, 2022 7:22 pm

Re: Cannot Connect to Dashboard

Post by KE8CLD »

Thanks, everything is good now. Much appreciated.
Rodger
Post Reply