AUTO AP Ip address

Help setting up WiFi
Post Reply
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

AUTO AP Ip address

Post by w4rss »

Is the auto ap ip address still 192.168.50.1 or has it changed. My pc shows the pistar name but the .50.1 address doesn't connect

Thanks
Dick
W4RSS
M1DNS
Pi-Star Team
Posts: 1158
Joined: Thu Apr 05, 2018 5:30 am

Re: AUTO AP Ip address

Post by M1DNS »

Yeah, hasnt changed AFAIK, but remember
Auto IP wont be available if the pi is connected to the web and already getting an ip address from ur router via wifi or lan cable.

Sent via smoke signals from my SM-G935F M1DNS (Admin)

Andrew M1DNS.
Pi-star Admin Team.
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

Re: AUTO AP Ip address

Post by w4rss »

Thanks, Andrew, I'll check that out.

Dick
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

Re: AUTO AP Ip address

Post by w4rss »

Further info:
Have started the pi-star and after a couple of minutes it shows connected.

It shows up on the pc wi-fi as pi-star which seems to mean it's connected to it's own network.

Clicked on pi-star in the network it gets connected and I enter the ip and then it is just a blank screen. Something is wonky for sure.

Additionally if I power up the ht and press the PTT the hot spot shows that it is hearing me.

Something is really strange.

I wonder if it would be good to create a new .conf file and give that a try?

Dick
M1DNS
Pi-Star Team
Posts: 1158
Joined: Thu Apr 05, 2018 5:30 am

Re: AUTO AP Ip address

Post by M1DNS »

At this point I'd prob be looking at re- burning the image back to the card and starting over as it sounds like something is goofy.

If can get to the dashboard run a backup so at the very least you can get back to where you are currently if starting over gives you even more of an issue.
(But i dont think it should)

Sent via smoke signals from my SM-G935F M1DNS (Admin)

Andrew M1DNS.
Pi-star Admin Team.
AF6VN
Posts: 763
Joined: Fri Jul 20, 2018 1:15 am

Re: AUTO AP Ip address

Post by AF6VN »

w4rss wrote: Wed Aug 31, 2022 3:34 pm Further info:
Have started the pi-star and after a couple of minutes it shows connected.
"Shows connected" where? On a router client page? On some LCD piggy-backed on the R-Pi?

The "Auto AP" is an access point mode -- it does NOT connect to anything; other devices are supposed to connect to IT to gain access to the configuration pages.
It shows up on the pc wi-fi as pi-star which seems to mean it's connected to it's own network.

Clicked on pi-star in the network it gets connected and I enter the ip and then it is just a blank screen. Something is wonky for sure.
Again, if it is the Access Point you are seeing, it is not connected to anything, you have to connect to it (as you claim you've done). Try using the name rather than the IP number. Or check the properties of your computer's WiFi interface to see what it gives... (I'm hard-wired so can't really show an example) ... since if you've disconnected from your normal router and connected to the access point (and it has no router connection) you should have received a DHCP IP address in the same network as the access point -- if the WiFi adapter IP address isn't 192.168.50.x you might not be able to "route" to 192.168.50.1

--
AF6VN
Dennis L Bieber
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

Re: AUTO AP Ip address

Post by w4rss »

Thanks for that. When I look at the available networks on my pc I do see pi-star. You may be correct that starting over is the best thing to do.

Dick
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

Re: AUTO AP Ip address

Post by w4rss »

More....

I put a new wpa_supplicant.conf file in the pi. it connected to my network and I can see it connected to my mesh system. I try to bring up the dashboard and nothing happens.

I'm more inclined now to think that the image needs to be redone.

I'll post results.

Dick
AF6VN
Posts: 763
Joined: Fri Jul 20, 2018 1:15 am

Re: AUTO AP Ip address

Post by AF6VN »

w4rss wrote: Wed Aug 31, 2022 9:06 pm I put a new wpa_supplicant.conf file in the pi. it connected to my network and I can see it connected to my mesh system. I try to bring up the dashboard and nothing happens.
What, exactly, have you entered in the browser? This is my entry (admin page, not basic dashboard -- and note that I'd changed the hostname long ago on the basis that I might add a second unit, to allow separate D-STAR and DMR nodes): http://pi-star-3b/admin/

If the bare hostname is not sufficient, you may need <hostname>.local, depending upon your router.

Also, some routers (and since you mention a mesh configuration) default to BLOCKING access to other WiFi/hard-wired clients within the LAN -- that is, they only allow WiFi clients to talk to the WAN ("Internet") side. For my router, that would be the "guest" SSID (which I've turned off completely); the other SSID allows for talking to WiFi clients from my hard-wired computer.

If your unit has an RJ-45 (Ethernet) socket, and you have a spare wire port on the router (or a network switch attached to the router), try using a wired connection and see if that allows connection by the browser. If it does, that would be a good indication that it is your WiFi network that is the problem.

--
AF6VN
Dennis L Bieber
w4rss
Posts: 18
Joined: Fri May 25, 2018 8:16 pm

Re: AUTO AP Ip address

Post by w4rss »

thanks again for that suggestion. I"ll try it week after next when we get back home.

Dick
Post Reply