dual_hat not working anymore

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
Post Reply
Posts: 2
Joined: Thu Sep 29, 2022 9:05 pm

dual_hat not working anymore

Post by m3tmh »

As title.... I'm running a generic dual hat with firmware: HS_Hat:v1.5.2, with the 12.28MHz osc. A while ago I think I upgraded MMDVM (possibly firmware too) and it doesn't work on RF anymore. I re-installed the dual hat 12.28MHz firmware via command line and still nothing. I've tried all the dual hat modem settings.

The SVC led flashes constantly now also. First slowly (about 2Hz), then faster.

Oddly, RF works fine when I call pistar-mmdvmcal and run the tests. On the homepage, the Trx field is blank. Brandmeister remote settings still work, I can set talkgroups via Brandmeister selfcare and they update on the mmdvm homepage.

I tried downgarding the FW back to an early version (via ssh) but I get the following error:

Code: Select all

Flashing your hs_dual_hat-12mhz modem to the v1.4.1 version
--2023-09-08 10:03:04--  https://github.com/juribeparada/MMDVM_HS/releases/download/v1.4.1/install_fw_hsdualhat-12mhz.sh
Resolving github.com (github.com)...
Connecting to github.com (github.com)||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2023-09-08 10:03:09 ERROR 404: Not Found.

I'd appreciate any insight into what's gone wrong here.
Sent from my full keypad GP300 using DTMF.
Posts: 29
Joined: Thu Nov 01, 2018 2:28 am

Re: dual_hat not working anymore

Post by AC8OB »

As the forum seems to be quiet I'll try and help as I've successfully updated a couple of these HS_DUAL_HATs to v1.5.2 recently.

The firmware you are trying to download is located here: https://github.com/juribeparada/MMDVM_H ... tag/v1.4.1 which may explain why the script is failing. You can browse the Github repo to verify this.

Firstly, try making sure you have applied all the pi-star updates as this may pick up a newer script with a changed location.
Open the SSH console and enter sudo pistar-update. Once you have done this, reboot your Pi.

When you have updated, can you identify your modem by running sudo pistar-findmodem?
Mine shows

Code: Select all

$ sudo pistar-findmodem
Detected MMDVM_HS Port: /dev/ttyAMA0 (GPIO) Baud: 115200 Protocol: V1 
	 Modem Data: MMDVM_HS_Dual_Hat-v1.5.2 20201108 14.7456MHz dual ADF7021 FW by CA6JAU GitID #89daa20FF5306695650877267252016
Nick - G4IRX - AC8OB
Post Reply