RepeaterBuilder v4 PTT not working

Help with other MMDVM Repeater Boards (with NO onboard RF)
Post Reply
kx9rt
Posts: 2
Joined: Mon Feb 18, 2019 3:02 am

RepeaterBuilder v4 PTT not working

Post by kx9rt »

I have a new v4 Pi-Hat board and trying to get the MMDVMcal working. I have it connected to a VXR9000 repeater in mixed mode. I can hear DMR audio on the TX audio output of the DB9 connector. But the PTT output LED or pin voltage does not toggle.

1. run sudo pistar-mmdvmcal
2. toggled TX/RX with spacebar. No PTT LED. Can hear audio directly on the DB9 output pin.
3. Tried inverting PTT polarity. No PTT LED.
4. Updated firmware from http://dvswitch.org/files/HAM/MMDVM/Ver ... dvm_f4.hex
5. No PTT LED toggling in mmdvmcal.

Using Pi-Star 4.1.7 (also tried WPSD with similar results)
Modem type set to STM32-DVM / MMDVM_HS - Raspberry Pi Hat (GPIO)

This is a new board received a couple weeks ago and have never had it on the air.

Can anyone confirm the Modem type is properly selected?

Did i update with the wrong firmware to cause other issues?

Any thoughts?

Scott, KX9RT
M1DNS
Pi-Star Team
Posts: 1376
Joined: Thu Apr 05, 2018 5:30 am

Re: RepeaterBuilder v4 PTT not working

Post by M1DNS »

If ur running f/w 1.6.1 on the board we're not quite ready to support that yet. Its in the works but we'll need to make changes to support the higher data rates of that firmware.

Sent via smoke signals using my SM-G935F

Andrew M1DNS.
Pi-star Admin Team.
Post Reply