Loss of ttyAMA0 with 4.2.0

Help with D-Star related issues
User avatar
G8SEZ
Posts: 555
Joined: Fri Apr 13, 2018 8:26 pm

Re: Loss of ttyAMA0 with 4.2.0

Post by G8SEZ »

MW0MWZ wrote: Sat Feb 17, 2024 12:59 pm Can we do some kind of remote session, I'd love to know more about how this is broken for you.

In the mean time I'll also do some more testing here and see if I can see what is up, the above cleaned mine up at least.
Should be possible, name your poison.

Just started up a live log and rebooted. As far as I can tell the problem is down to the OLED display handling, the log runs as normal and sits there with this content:

Starting logging, please wait...
I: 2024-02-17 12:51:54.871 MMDVM protocol version: 1, description: MMDVM_HS_Hat-v1.6.1 20230526 14.7456MHz ADF7021 FW by CA6JAU GitID #7ff74ed
I: 2024-02-17 12:51:54.891 Display Parameters
I: 2024-02-17 12:51:54.891 Type: OLED
I: 2024-02-17 12:51:55.246 Opening network connections
I: 2024-02-17 12:51:55.246 DMR Network Parameters
I: 2024-02-17 12:51:55.246 Type: Direct
I: 2024-02-17 12:51:55.246 Remote Address: 78.129.135.43
I: 2024-02-17 12:51:55.246 Remote Port: 55555
I: 2024-02-17 12:51:55.246 Local Address:
I: 2024-02-17 12:51:55.246 Local Port: 0
I: 2024-02-17 12:51:55.246 Jitter: 300ms
I: 2024-02-17 12:51:55.246 Slot 1: disabled
I: 2024-02-17 12:51:55.246 Slot 2: enabled
I: 2024-02-17 12:51:55.246 Mode Hang: 10s
I: 2024-02-17 12:51:55.247 Info Parameters
I: 2024-02-17 12:51:55.247 Callsign: G8SEZ
I: 2024-02-17 12:51:55.247 RX Frequency: 438637500Hz
I: 2024-02-17 12:51:55.247 TX Frequency: 438637500Hz
I: 2024-02-17 12:51:55.247 Power: 0W
I: 2024-02-17 12:51:55.247 Latitude: 52.104099deg N
I: 2024-02-17 12:51:55.247 Longitude: -0.375000deg E
I: 2024-02-17 12:51:55.247 Height: 1m
I: 2024-02-17 12:51:55.247 Location: "Bedford, IO92TC"
I: 2024-02-17 12:51:55.247 Description: "UK"
I: 2024-02-17 12:51:55.247 URL: "https://www.qrz.com/db/G8SEZ"
I: 2024-02-17 12:51:55.247 Options: StartRef=4440;RelinkTime=60;UserLink=1
M: 2024-02-17 12:51:55.247 DMR, Opening DMR Network
I: 2024-02-17 12:51:55.247 RSSI
I: 2024-02-17 12:51:55.247 Mapping File: /usr/local/etc/RSSI.dat
I: 2024-02-17 12:51:55.253 Loaded 14 RSSI data mapping points from /usr/local/etc/RSSI.dat
I: 2024-02-17 12:51:55.253 DMR Id Lookups
I: 2024-02-17 12:51:55.253 File: /usr/local/etc/DMRIds.dat
I: 2024-02-17 12:51:55.253 Reload: 24 hours
I: 2024-02-17 12:51:55.253 Loading ID lookup table from /usr/local/etc/DMRIds.dat
I: 2024-02-17 12:51:58.324 Loaded 254056 IDs to lookup table - /usr/local/etc/DMRIds.dat
I: 2024-02-17 12:51:58.325 Starting protocol handlers
I: 2024-02-17 12:51:58.325 DMR RF Parameters
I: 2024-02-17 12:51:58.325 Started the DMR Id lookup reload thread
I: 2024-02-17 12:51:58.325 Id: 234182802
I: 2024-02-17 12:51:58.325 Color Code: 1
I: 2024-02-17 12:51:58.325 Self Only: yes
I: 2024-02-17 12:51:58.325 Embedded LC Only: no
I: 2024-02-17 12:51:58.325 Dump Talker Alias Data: yes
I: 2024-02-17 12:51:58.325 Prefixes: 0
I: 2024-02-17 12:51:58.325 Call Hang: 3s
I: 2024-02-17 12:51:58.325 TX Hang: 3s
I: 2024-02-17 12:51:58.325 Mode Hang: 10s
I: 2024-02-17 12:51:58.325 OVCM: off
I: 2024-02-17 12:51:58.325 DMR Roaming Beacons Type: off
I: 2024-02-17 12:51:58.333 Interfaces Info
I: 2024-02-17 12:51:58.333 IPv4: lo:127.0.0.1
I: 2024-02-17 12:51:58.333 IPv4: wlan0:10.0.0.145
I: 2024-02-17 12:51:58.333 Default interface is : wlan0
I: 2024-02-17 12:51:58.333 IP to show: wlan0:10.0.0.145
M: 2024-02-17 12:51:58.447 Mode set to Idle
I: 2024-02-17 12:51:58.447 MMDVMHost-20240210_PS4 is running
M: 2024-02-17 13:09:46.866 DMR, Logged into the master successfully
M: 2024-02-17 13:09:47.287 DMR Slot 2, received network late entry from 4440 to TG 9
M: 2024-02-17 13:09:47.293 Mode set to DMR
M: 2024-02-17 13:09:53.872 DMR Slot 2, received network end of voice transmission from 4440 to TG 9, 6.6 seconds, 0% packet loss, BER: 0.0%
M: 2024-02-17 13:10:04.023 Mode set to Idle

The display keeps cycling, shows -OFFLINE- then normal output for a second or two before 'Stopping' and then back to -OFFLINE-
--

Brian G8SEZ
User avatar
MW0MWZ
Site Admin
Posts: 1505
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Loss of ttyAMA0 with 4.2.0

Post by MW0MWZ »

OK sent you a PM, let's get that setup and see what's what.
Andy

73 de MW0MWZ
http://pistar.uk
Post Reply