4.3.0 Beta feedback

General support for the Pi-Star System
User avatar
IW4EHJ
Posts: 13
Joined: Sun Jan 21, 2024 1:32 pm
Location: Rimini Italia
Contact:

Re: 4.3.0 Beta feedback

Post by IW4EHJ »

Tried version 4.3.0 but encountered the same problem as 4.2.0 (while 4.1.8 works correctly).

After preparing the SD and reloading the configuration it seems to work well, but after completing all the updates and applying it in the configuration without actually changing anything the MMDVM modem is no longer recognized and always remains red even by doing sudo pistar-findmodem I can't find anything anymore .

I tried to restart the Pi-Star, reload the configuration and also a restore but nothing, the MMDVM modem is no longer available (it always remains red) and the only way to use it is to redo the SD and not do any updates this is how it works (4.2.0 also behaves this way).

I don't know what it could be, I see that others are experiencing the same problem on both versions.

Good job, I hope the situation gets resolved.
User avatar
MW0MWZ
Site Admin
Posts: 1505
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: 4.3.0 Beta feedback

Post by MW0MWZ »

I'll try and squash some of these issues over the weekend.
Andy

73 de MW0MWZ
http://pistar.uk
K9DJN
Posts: 38
Joined: Mon Dec 24, 2018 6:25 pm

Re: 4.3.0 Beta feedback

Post by K9DJN »

I tried the re-spin, made a fresh SD card. Still will not see the original ZumSpot. Here is the pertinent part of the MMDVM log:

M: 2024-02-17 15:40:19.363 Opening the MMDVM
E: 2024-02-17 15:40:19.363 Cannot get the control attributes for /dev/ttyAMA0
I: 2024-02-17 15:40:19.364 MMDVMHost-20240126_PS4 exited on receipt of an unknown signal

This is on an RPi3B with a ZumSpot board running 1.6.1 firmware. Still works fine with beta 4.2.0. Same log lines from that version:

M: 2024-02-17 15:17:33.353 Opening the MMDVM
I: 2024-02-17 15:17:35.364 MMDVM protocol version: 1, description: ZUMspot-v1.6.
1 20230526 14.7456MHz ADF7021 FW by CA6JAU GitID #7ff74ed

Doug
K9DJN
2E0BSL
Posts: 3
Joined: Sun Jan 21, 2024 8:17 pm

Re: 4.3.0 Beta feedback

Post by 2E0BSL »

Update. Installed 4.3.0 fresh without menu update and it runs fine. The update caused lockup, inability to access remotely.

Using pi zero v1. DMR mode. Generic jumbo spot gpio clone, headless.
PA5WIL
Posts: 16
Joined: Sun Apr 15, 2018 10:15 am

Re: 4.3.0 Beta feedback

Post by PA5WIL »

I have now 4.30 on a raspberry pi 5. I have to restart several times to have connection with wifi
PA5WIL
Posts: 16
Joined: Sun Apr 15, 2018 10:15 am

Re: 4.3.0 Beta feedback

Post by PA5WIL »

MW0MWZ wrote: Fri Feb 09, 2024 10:49 pm
K4CQO wrote: Fri Feb 09, 2024 8:46 pm Can the 4.3 version be burned to a USB drive and then used as a boot drive on a pi?
Not sure, never been interested in doing so.
I also want to boot pi-star from an NVMe drive on my raspberry Pi 5
KA1PIT
Posts: 4
Joined: Sun Jun 06, 2021 11:27 am

Re: 4.3.0 Beta feedback

Post by KA1PIT »

Using Image 4.3.0 Feb 10 and todays update(March 4, 2024),
I can not Connect to KC Wide by hitting the AMS button on the Yeasu FT-70d.

The dashboard shows me transmitting constantly , so I have to reboot.

Yaesu System Fusion Configuration block, YSF host Startup is set to FCS00290 America-Link-WiresX
that works fine, but doing the AMS button to try to connect to KC Wide I get the transmit on the dashboard.

Pi-star 4.3.0
Dashboard 20240227
FW 1.6.1
Rp Zero W V1.6.1

This problem doesn't happen with 4.1.8 16-Feb
PA5WIL
Posts: 16
Joined: Sun Apr 15, 2018 10:15 am

Re: 4.3.0 Beta feedback

Post by PA5WIL »

i have now the problem that the Nextion Display is not working anymore. I have made a new image but no succes.
PA5WIL
Posts: 16
Joined: Sun Apr 15, 2018 10:15 am

Re: 4.3.0 Beta feedback

Post by PA5WIL »

Boot from the nvme ssd drive is now working. I followed the instructions on the website https://github.com/kn2tod/pistar-boot-from-usb.
I setup a new image on sd card and make the change to bootup from usb ssd. On the raspberry pi put the pistar cdcard in the slot of the pi and the nvme ssd drive in a usb adapter. I use the sd copier in the software from the pi to clone the sd card to the nvme ssd in the usb adapter. Then i install the nvme on the Greekworm adapter. And now pistar boot from the nvme ssd drive. It is a overkill but it is a hobby and i like to do experiment.

Only the Nextion Display works often not. This was also with pistar on the sd card.
I have now pistar on a Raspberry Pi 5 withe nvme drive.
KN2TOD
Posts: 269
Joined: Sun Nov 11, 2018 6:36 pm

Re: 4.3.0 Beta feedback

Post by KN2TOD »

Out of curiosity, what results do you get for these commands?

Code: Select all

ls -la /dev/ttyAM*

Code: Select all

sudo systemctl status nextiondriver.service

Code: Select all

grep -shie "NextionDriver: " {/var/log/syslog.1,/var/log/syslog}
Last edited by KN2TOD on Fri Apr 05, 2024 12:37 pm, edited 1 time in total.
Post Reply