Weird problem with YSF on duplex MMDVM Hotspot

Help with YSF / Fusion issues
Post Reply
Posts: 10
Joined: Tue Apr 07, 2020 2:49 pm

Weird problem with YSF on duplex MMDVM Hotspot

Post by 2E0PJY »

Hello all

This is really got me totally stumped so I would be grateful for any pointers from this knowledgeable group!

I have a duplex MMDVM Chinese clone board, running on a PI4 using the latest software and updates, I have flashed the modem and it works absolutely great on DMR. I have YSF enabled also but that doesnt work so well, the problem I have is as follows (excuse my explanation!).

When I make a transmission linked to any reflector or room, upon releasing the PTT I receive a short (approx half a second) retransmission of my signal. I have tried this by using the parrot and it works like this:

PTT pressed, say a message and then release the PTT. Almost immediately from unkeying I receive a quick burst of the message which then also unkeys. I then receive the full message retransmitted to me. I thought initially it was some form of standby bleep or tail transmission but checking it on another radio it receives the same.

Sorry if this is unclear and I wonder if its anything to do with the fact that I am using a duplex board but I have tried everything to rectify without success. BER fluctuates but is between 0.8 - 1.2% and I am using DMR, YSF, and YSF2DMR, YSF2P25 and YSF2NXDN via DMRGATEWAY.

Any help would be appreciated!

Posts: 1
Joined: Fri Jun 21, 2024 11:14 pm

Re: Weird problem with YSF on duplex MMDVM Hotspot

Post by kc3yqi »

I have the same problem using YSF mode in repeater mode with my FT-991a.

I'll connect to the parrot, YSF room 99999. I'll PTT, say, "This is KC3YQI. Testing my hotspot".

Immediately after I release the PTT I hear a "my hotspot" or some other fragment of the ending of my message. If I pause longer at the end, I hear less of it, but still see a blip of TX from the hotspot.

A second or two later the parrot will say the entire message.
I've tried other rooms and it happens there too.

I don't have an answer for you; only another data point. If I find an answer, I'll let you know.

MMDVM: Aursinc MMDVM duplex hotspot module
Modem type: STM32-DVM / MMDVM_HS Raspberry Pi Hat (GPIO)
Pi-Star: 4.2.1
Dashboard: 20240307
Radio: FT-991a
Posts: 41
Joined: Thu Nov 01, 2018 2:28 am

Re: Weird problem with YSF on duplex MMDVM Hotspot

Post by AC8OB »

Because it's a duplex hotspot it is re-transmitting your signal at the same time but you can' year it while your radio is in TX. If you have another fusion radio and listen on the hotspot TX frequency you'll hear it while you are transmitting. There is slight delay (latency) due to the processing time in the modem, cpu etc.
Nick - G4IRX - AC8OB
Post Reply