OLED dies

All things relating to OLED Screen(s)
Post Reply
WU0V
Posts: 38
Joined: Wed Apr 11, 2018 2:26 pm

OLED dies

Post by WU0V » Mon Sep 10, 2018 6:26 pm

In the past 6 months or so I’ve had two of the .96” yellow/blue OLED displays go dead. No apparent reason, they’re perking along just fine and then they’re blank and cannot be revived by any method I can find on Google. The hotspot PS is plugged in to a UPS/line filter of a reputable brand and nothing else on that circuit has problems, so I assume it’s not a power glitch. My PS provides all the amps the hotspot can drink. Jumbospot on Pi ZW, up 24/7.
Have others had hotspot OLEDs fail? Maybe its internal components have just had a hiccup and need a reset, and if so is there a way to revive them?
I switched to my Nextion screen and it’s fine. I realize the Nextion is on a different port so I can’t rule out a port failure for the OLED but I think it’s unlikely.

Lee, WU0V. 59 years a ham, still having fun

User avatar
VK7HSE
Posts: 153
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: OLED dies

Post by VK7HSE » Wed Sep 12, 2018 5:27 pm

The oled screens don't like running on 5v they prefer 3.3v (although I'd say that you already know this)

Sent from my Pixel 2 XL using Tapatalk


2w0tax
Posts: 3
Joined: Sun Aug 19, 2018 8:03 am

Re: OLED dies

Post by 2w0tax » Sat Mar 16, 2019 5:19 pm

I have the same problem with my Oled its totally dead, have not even had it a month and after a few nights of displaying its gone totally dead. I thought it might be something to do with my soldering, tried desoldering and cleaning up the old joint before soldering again with no joy have even gone as far as reflashing the sdcard with a new downlad of pi-star, this has not made any difference at all, so looks like the Oled is destined for the bin.

EA3BIL
Posts: 26
Joined: Tue Apr 17, 2018 11:45 pm

Re: OLED dies

Post by EA3BIL » Tue Jun 18, 2019 11:30 am

Hi,

I've assembled about a dozen HS using simplex MMDVM boards and the OLED screens showing in the attached images.
They ALL are still working for more than ONE YEAR (the older ones).

Maybe you are getting wrong Oled models...
Attachments
OLED_BACK.jpg
Back viewing
OLED_BACK.jpg (95.53 KiB) Viewed 81 times
OLED_FRONT.jpg
Front viewing
OLED_FRONT.jpg (79.6 KiB) Viewed 81 times

Post Reply