Need to double transmit to do anything YSF

Help with YSF / Fusion issues
Post Reply
kz8bay
Posts: 3
Joined: Mon Dec 31, 2018 5:42 pm

Need to double transmit to do anything YSF

Post by kz8bay » Wed Jan 02, 2019 1:59 am

I have d-star and YSF enabled on my zumspot pi setup, and if i wan't to do anything with YSF i have to send it twice in close succession. For example, to enter wires-x, I have to hit the Dx button (FT1D) and then wait for it to finish transmitting, and then hit it again. It looks like it may be switching back and forth between listening to d-star and YSF and then the first part of the transmission gets cut off when it realizes it's YSF. I could also be totally wrong about how it works.. but I do know that I have to do this for everything, room searches, room connects, etc. Anyone have any ideas? Could it just be a configuration issue (radio or zumspot/pi-star)?

MW0MWZ
Site Admin
Posts: 518
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Need to double transmit to do anything YSF

Post by MW0MWZ » Thu Jan 03, 2019 3:46 pm

When you have more than one mode enabled - the modem flips back and forth when its idle to work out what mode is being transmitted, so you need a longer blast of RF for it to work that out, the wires X button only sends a very short one, this is why you see the outcome that you see.
Andy

73 de MW0MWZ
http://pistar.uk

kz8bay
Posts: 3
Joined: Mon Dec 31, 2018 5:42 pm

Re: Need to double transmit to do anything YSF

Post by kz8bay » Fri Jan 04, 2019 5:33 pm

Ok, thanks for the clarification

MW0MWZ
Site Admin
Posts: 518
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Need to double transmit to do anything YSF

Post by MW0MWZ » Fri Jan 04, 2019 9:49 pm

Some things that help with this...
1. Use only one mode - yeah I know, probably not what you want - but that totally eliminates the issue.

2. Set the hang timers *longer* - so I have mine set to 90secs for RF and 20secs for Network, this works great for me, 90 secs on RF is long enough that when I want to QSO with someone, the mode sticks and I don't have to mess about, 20 secs for network, again, its enough for the QSO I am listening to not to be lost in mode hops. I know its tempting to set these to maybe 3 secs, but mostly that will aggravate you as your hotspot jumps modes at all the wrong times :)

Finally, my top tip - unlink the modes you are not focussed on right now - so if you want YSF, unlink the D-Star reflector - sure there will be those times you are monitoring them both - so sure have them both linked - but when you want to use YSF, unlink D-Star, when you want to use D-Star, unlink YSF.
Andy

73 de MW0MWZ
http://pistar.uk

Post Reply