Cannot Get Nextion to work under Pi-Star

All things relating to the Nextion Screen(s)
Post Reply
N4NQY
Posts: 56
Joined: Thu Apr 12, 2018 5:47 pm

Cannot Get Nextion to work under Pi-Star

Post by N4NQY » Sun Jan 06, 2019 8:54 pm

I am trying to add a 3.2 Nextion to my MMDVM_HS Duplex. After adding a Header and pluging it in, all I get is the INFO/Status screen on the Nextion. The TX and RX wires are correct. I have tried all the Port options in Pi-Star and most of the layouts. No difference at all.

Any idea what I am doing wrong? Latest Pi-Star image with all updates.

Getting pretty disgusted with myself since I cannot seem to fix the problem/

N4NQY
Posts: 56
Joined: Thu Apr 12, 2018 5:47 pm

Re: Cannot Get Nextion to work under Pi-Star

Post by N4NQY » Sun Jan 06, 2019 9:20 pm

Additional information. I attached the screen to another Pi-Star hotspot I have with the same results. Must be a Pi-Star setting. I notice that the Full Edit of MMDVM.ini is no longer available and I am not sure where to find it. Probably gets rewritten every update however.

Struggling.

2E0LGZ
Posts: 57
Joined: Sat Jun 16, 2018 3:10 pm

Re: Cannot Get Nextion to work under Pi-Star

Post by 2E0LGZ » Mon Jan 07, 2019 12:29 pm

Have you tried another nextion screen file instead of the one you are using now? or re installing the file via usb ttl rather than sd card?
Gary

W9KJO
Posts: 41
Joined: Sun Apr 22, 2018 5:58 pm

Re: Cannot Get Nextion to work under Pi-Star

Post by W9KJO » Mon Jan 07, 2019 12:37 pm

N4NQY wrote:
Sun Jan 06, 2019 8:54 pm
I am trying to add a 3.2 Nextion to my MMDVM_HS Duplex. After adding a Header and pluging it in, all I get is the INFO/Status screen on the Nextion. The TX and RX wires are correct. I have tried all the Port options in Pi-Star and most of the layouts. No difference at all.

Any idea what I am doing wrong? Latest Pi-Star image with all updates.

Getting pretty disgusted with myself since I cannot seem to fix the problem/
I had this same problem and the issue was the firm ware in the MMDVM. I had to roll it back one version and the screeen started to work.

73, W9KJO

kp4djt
Posts: 14
Joined: Wed Feb 06, 2019 12:40 am

Re: Cannot Get Nextion to work under Pi-Star

Post by kp4djt » Tue Feb 12, 2019 7:50 am

I am having the same issue. I have checked all of the wiring TX>RX RX>TX, I just see the MMDVM logo on the screen but get no data on there. I see the comment about rolling back the MMDVM software to the previous rev level, have not done that, what is the trick? I see and have used the command to update the modem to the latest, indeed it took me a bit to get it to work but I stumbled onto a comment that they did multiple updates to the modem at which point it started working, I did the same thing and got the same results, took me about 4 update tries until it would start to work. But I cannot get the Nextion screen to show anything, and I believe it is probably that nothing is getting there.
My setting are
MMDVM Display Type: Nextion , Port: Modem, Nextion Layout: G4KLX
Expert Screen Nextion section
Port Modem
Brightness 50
DisplayClock 1
UTC 0
ScreenLayout 0
IdleBrightness 20

I can find descriptions for all but ScreenLayout. I have tried other numbers there but no joy.

The modem is a duplex dual hat on /dev/ttyAMA0

I suppose that I could test the screen by putting it on a RPi and testing it direct correct?

kp4djt
Posts: 14
Joined: Wed Feb 06, 2019 12:40 am

Re: Cannot Get Nextion to work under Pi-Star

Post by kp4djt » Sat Feb 16, 2019 6:27 am

I found out how to do the roll back, did it but no joy. I still have a nice blank screen, any other ideas out there?

Post Reply