DVMEGA firmware process doesn't work with 4.0.0-RC3

DV-Mega Single / Dual band Hat for the Raspberry Pi
Post Reply
User avatar
KE0FHS
Posts: 568
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

DVMEGA firmware process doesn't work with 4.0.0-RC3

Post by KE0FHS » Thu Jan 24, 2019 2:14 am

Was just trying to help someone troubleshoot an issue with being unable to upgrade DVMEGA firmware from 3.19 to 3.26. Using the instructions at https://amateurradionotes.com/pi-star-notes.htm#viarpi, I was able to successfully run a firmware upgrade on my DVMEGA-DUAL + RPi 3B hotspot running Pi-Star 3.4.17. Then I upgraded the hotspot to 4.0.0-RC3 and tried running the firmware upgrade again and it failed. Log follows below.

I'm not great at reading and interpreting logs, but it looks to me like the problem is here:

Code: Select all

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/root/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping
Seem like some files that were present in 3.4.17 are not longer present, at least not in the same location, in 4.0.0-RC3.

Code: Select all

[email protected](ro):dvmega$ sudo ./flash_gpio.sh
Warning: Stopping pistar-watchdog.service, but it can still be activated by:
  pistar-watchdog.timer
Warning: Stopping dstarrepeater.service, but it can still be activated by:
  dstarrepeater.timer
Found DVMEGA_RH_V326_RPI.hex firmware...

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/root/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyAMA0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Once flashing has been completed, you should reboot your Pi-Star
[email protected](ro):dvmega$ 
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
http://pi-star.hamnotes.com

User avatar
KE0FHS
Posts: 568
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: DVMEGA firmware process doesn't work with 4.0.0-RC3

Post by KE0FHS » Thu Jan 24, 2019 5:05 pm

FYI, I just downloaded a fresh install of 3.4.17 (Pi-Star_RPi_V3.4.17_20-Jan-2019.zip), booted it up, added initial configuration settings, rebooted, ran an update and upgrade, rebooted, and then ran a successful firmware upgrade on my DVMEGA-DUAL. So that confirms to me that there is an issue in 4.0.0-RC3 with the DVMEGA firmware upgrade process.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
http://pi-star.hamnotes.com

G6MJQ
Posts: 5
Joined: Wed Apr 11, 2018 12:24 pm

Re: DVMEGA firmware process doesn't work with 4.0.0-RC3

Post by G6MJQ » Thu Feb 21, 2019 7:59 pm

For the record I'm finding the same with 4.0.0-RC3.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
....... etc....

Tries 10 times and fails.

Adrian
G6MJQ

G6MJQ
Posts: 5
Joined: Wed Apr 11, 2018 12:24 pm

Re: DVMEGA firmware process doesn't work with 4.0.0-RC3

Post by G6MJQ » Thu Feb 21, 2019 9:23 pm

Went back to Pi-Star V3.4.17 and DVMEGA firmware updated just fine to 3.26 just to confirm problem with 4.0.0-RC3.

Post Reply