ipv4.fw not being read?

All IP networking related issues
Post Reply
kp4djt
Posts: 14
Joined: Wed Feb 06, 2019 12:40 am

ipv4.fw not being read?

Post by kp4djt » Fri Feb 15, 2019 5:57 am

I am running my system on the 3B+, so I am using the code for that machine. It appears that the ipv4.fw file is not being read, I have a rule I added so I can get to gkrellmd, but it does not appear to pick it up.

On my 3B board it works just fine. Has anyone noticed this?

In order to get it to work, I actually edited the iptables.rules file.

k2dls
Posts: 37
Joined: Mon Aug 20, 2018 5:24 pm

Re: ipv4.fw not being read?

Post by k2dls » Fri Feb 15, 2019 2:51 pm

I am using ipv4.fw on a 4.0 RC3 system and used it previously on 3.x. I can confirm that it does work fine for me and that the firewall ruleset is updated as expected. What is the directory location and contents of the file?

kp4djt
Posts: 14
Joined: Wed Feb 06, 2019 12:40 am

Re: ipv4.fw not being read?

Post by kp4djt » Sat Feb 16, 2019 3:50 am

The file is in /root, here is the contents:
#Custom FW script
# Open port for gkrellmd found on 19150
iptables -A INPUT -p tcp -m tcp --dport 19150 -j ACCEPT

This is running just fine on my 3B, but on my 3B+ I had to go in and add it to the FW file. I do not know why it is not pulling it in. Was trying to figure out how to test for what iptables is looking at.

I can get to gkrellmd either by totally turning off the FW (not good) or putting the INPUT line in the FW script, but it will not see the ipv4.fw file. Trying to figure out what else to pass on.

While writing this, I went back and looked at the working and non-working files, both in root, indeed one is a copy of the other one. BUT even though PI-star would not allow me to enter the file unless I had sudo'd in, it had set the owner and group as pi-star pi-star vice root root. But that did not fix it either. I just went back into iptables.rules and added my rule back, restarted and I am able to access gkrellmd. So just have to figure what is going on and fix it.

By way I have seen several indications of going into root and changing something. I have found that I have to change the permissions to go in there otherwise it will not let you in.

k2dls
Posts: 37
Joined: Mon Aug 20, 2018 5:24 pm

Re: ipv4.fw not being read?

Post by k2dls » Sat Feb 23, 2019 1:42 pm

I don't know if this will make a difference, but I did notice on both of my pistar installations that the ipv4.fw file is owned by mmdvm:mmdvm.

PE1GFP
Posts: 5
Joined: Sun Sep 30, 2018 8:06 am

Re: ipv4.fw not being read?

Post by PE1GFP » Sun Feb 24, 2019 9:34 am

Got the same problem here. With RC3, added two lines in ipv4.fw, and subsequently they aren't read.

I tried 'chgrp' and 'chown' to 'mmdvm' but that didn't work (well, 'chgrp' and 'chown' did work ofcourse).

I also tried to misspell 'ipv4.fw' but to no avail.

See what comes up...

PE1GFP
Posts: 5
Joined: Sun Sep 30, 2018 8:06 am

Re: ipv4.fw not being read?

Post by PE1GFP » Sun Feb 24, 2019 9:55 am

I think I got it. Have you tried 'sudo pistar-firewall' after the change?

'73 Jan

MW0MWZ
Site Admin
Posts: 727
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: ipv4.fw not being read?

Post by MW0MWZ » Fri May 17, 2019 9:32 pm

Or run an update...

Instructions here: http://wiki.pistar.uk/Adding_custom_fir ... to_Pi-Star
Andy

73 de MW0MWZ
http://pistar.uk

Post Reply