Nextion via GPIO for Version 8

All things relating to the Nextion Screen(s)
Post Reply
WD0AJG
Posts: 4
Joined: Sat Apr 14, 2018 6:29 am

Nextion via GPIO for Version 8

Post by WD0AJG » Tue Mar 12, 2019 4:59 am

In several post here and Facebook Rob indicates that the two-way communication for version 8 screen will work If connection is to GPIO. I have attemped this but failed so, I have these questions:
1. Will Version 8 work two-way commands such as shutdown connected to the GPIO pins with out the USB to TTL?.
2. If so Which GPIO pins are used (I have assumed pwr (2 or 4),gnd (6), and pin 8 and 10 txd/rxd). I used this connection to a screen with the Nextion drivers installed on the pistar but only get the version 8 "started" screen then some seconds later the "stopped" screen...
3. so I conclude I need to change something in the software addressing of pistar but do not know what. or it truely requires the USB to TTL to talk to the processor

I found this old info on nextion to GPIO: http://wiki.pistar.uk/Nextion_Screen_install_on_Pi-Star
but the initial commands of : sudo raspi-config, Option 9, Option A8 NO
are confusing and do not work, actually I do not know where to find raspi-config. (not being more than a beginner here) since this is probably very dated material I am not sure any of these work anymore?

So I am still in search of learning here. or should I just wait for the "fabled" ability between modem and pi to do this, as that too has been hinted at in several places as the future possibility.

WD0AJG

AF4FA
Posts: 9
Joined: Wed Jan 23, 2019 6:20 pm

Re: Nextion via GPIO for Version 8

Post by AF4FA » Fri Mar 15, 2019 11:55 pm

You might want to look at this link.
https://github.com/PD0DIB/Nextion_HAM-r ... -by-ON7LDS

WD0AJG
Posts: 4
Joined: Sat Apr 14, 2018 6:29 am

Re: Nextion via GPIO for Version 8

Post by WD0AJG » Sat Mar 16, 2019 2:57 pm

Followed that exactly and that is what I described, it didn't work for me. so back to the USB connection. Maybe I had the wrong pins.??? as it does not explicitly identify which pins, maybe I missed something else? Not sure why it doesn't work here and so far I can not find anyone that is actually using the GPIO pins without the USB?

WD0AJG

Post Reply