WARNING: The Modem selection has been updated...

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
Post Reply
KA2UGZ
Posts: 9
Joined: Fri Feb 08, 2019 6:31 pm
Location: Bohemia NY

WARNING: The Modem selection has been updated...

Post by KA2UGZ » Sat Mar 16, 2019 11:42 pm

Not sure why I am seeing this screen now. All was working, now I am getting this message saying "WARNING: the Modem section has been updated, Please re-select your modem from the list" I hit "OK" and I get a blank BLACK screen.

The URL line is 192.168.2.161/admin/configure.php and a refresh gets ,e back to "WARNING". It seems to be an infinite loop and I can't get to an actual configuration screen to see what the modem is set for.

This happens anytime I try to select CONFIG. I did use the UPDATE feature today and the pi-star was functioning after that and made calls and contacts. I'm not sure why this has happened as I didn't change anything so not sure why I am getting the warning. If I just go to the ip address using a browser (192.168.2.161) it will eventually get to the DASHBOARD and I can select ADMIN then do POWER, UPDATE etc but if I select CONFIGURATION I get that warning screen.

This is a Pi-0 with Jumbospot HAT.

Thanks for looking - de KA2UGZ Jay

M1DNS
Posts: 341
Joined: Thu Apr 05, 2018 5:30 am

Re: WARNING: The Modem selection has been updated...

Post by M1DNS » Sat Mar 16, 2019 11:59 pm

Maybe, Try pulling down another update.
Sounds like the first one didn't complete as expected.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

KA2UGZ
Posts: 9
Joined: Fri Feb 08, 2019 6:31 pm
Location: Bohemia NY

Re: WARNING: The Modem selection has been updated...

Post by KA2UGZ » Sun Mar 17, 2019 12:14 am

The BLACK screen eventually updates after several minutes. I was able to get the CONFIGURATION screen to load, set the HAT, hit APPLY and saw a brief message about error reading configuration file. I'm going to reformat the SDCARD and try again. Thanks.

M1DNS
Posts: 341
Joined: Thu Apr 05, 2018 5:30 am

Re: WARNING: The Modem selection has been updated...

Post by M1DNS » Sun Mar 17, 2019 12:20 am

Try a factory reset, Similar to a reformat. not as severe as to wiping the actual card, but rebuilds the file structure. If you have a corrupt file a FR might repair it.

Andrew M1DNS, (Mod)


Andrew M1DNS.
Pi-star Admin Team.

KA2UGZ
Posts: 9
Joined: Fri Feb 08, 2019 6:31 pm
Location: Bohemia NY

Re: WARNING: The Modem selection has been updated...

Post by KA2UGZ » Sun Mar 17, 2019 4:48 am

Thanks for the help. I did the reformat and started over and it is working now. Didn't see your last reply until after I formated the card.

73 de KA2UGZ Jay

M1DNS
Posts: 341
Joined: Thu Apr 05, 2018 5:30 am

Re: WARNING: The Modem selection has been updated...

Post by M1DNS » Sun Mar 17, 2019 9:24 am

Ok jay. Glad it's now working agn.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

KA2UGZ
Posts: 9
Joined: Fri Feb 08, 2019 6:31 pm
Location: Bohemia NY

Re: WARNING: The Modem selection has been updated...

Post by KA2UGZ » Sun Mar 17, 2019 2:58 pm

One more detail I determined that might help someone else is that the BLACK screen seems to be coming from the recent CHROME browser updates to Android. I have been able to replicate this on a Google Pixel phone and a Samsung tablet, both using CHROME browser to access the pi-star configuration page.

If you get the WARNING message about having changed the modem type, click the OK in the dialog box. If you then get a blank BLACK screen try swiping up/down (touch panel) in the browser. The refresh-arrow will just bring back the WARNING message with the OK prompt. On my browsers, I can also short-press the power key to put the screen in power save then use the HOME button to wake the screen at which time the regular configuration page is displayed and then I can set the Radio/Modem Type option in the General Configuration block.

73 de ka2ugz Jay

User avatar
KE0FHS
Posts: 722
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: WARNING: The Modem selection has been updated...

Post by KE0FHS » Sun Mar 17, 2019 5:09 pm

KA2UGZ wrote:
Sun Mar 17, 2019 2:58 pm
One more detail I determined that might help someone else is that the BLACK screen seems to be coming from the recent CHROME browser updates to Android. I have been able to replicate this on a Google Pixel phone and a Samsung tablet, both using CHROME browser to access the pi-star configuration page.
FYI, I'm not experiencing this: MMDVM_HS_Hat, RPi 3A+, Pi-Star 4.0.0-RC3 (20190310), Pixel 3 Android 9 (March 5, 2019) running as a hotspot, Chrome 73.0.3683.75 (latest available).

Although I don't get the "Re-select your modem from the list" message, I did try applying changes, and it works perfectly.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply