Warning: loading old HMI files into the latest Nextion Editor .58

All things relating to the Nextion Screen(s)
KE7FNS
Posts: 222
Joined: Wed Apr 17, 2019 11:11 pm

Warning: loading old HMI files into the latest Nextion Editor .58

Post by KE7FNS » Fri Jul 19, 2019 3:14 am

So it looks like itead has made some significant changes to the editor, so much so that I instantly noticed the display fonts are skewed so badly they are pretty much unreadable.

their changelog says this:

Code: Select all

— If your HMI project was developed via 0.53 or prior version Nextion Editor, we recommend you to use the LTS version for project maintenance as the latest 0.58 version is not fully compatible with your exsisting source code and GUI desgin.
I've also experienced a few crashes to desktop while plinking around with it, so it might not be worth updating. I see some new features but those are only enabled for the new intelligent series (p) displays.

User avatar
KE0FHS
Posts: 915
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by KE0FHS » Fri Jul 19, 2019 12:37 pm

Whoa, thanks for the warning.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

K3TOM
Posts: 13
Joined: Fri May 31, 2019 2:08 am

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by K3TOM » Tue Aug 06, 2019 6:23 am

So is there any way we can edit those older HMI files? I ran into this the other day with a file I was trying to make some changes to.

KE7FNS
Posts: 222
Joined: Wed Apr 17, 2019 11:11 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by KE7FNS » Tue Aug 06, 2019 8:34 am

K3TOM wrote:
Tue Aug 06, 2019 6:23 am
So is there any way we can edit those older HMI files? I ran into this the other day with a file I was trying to make some changes to.
Yes, just you can use the LTS version, it is essentially the old software version without the latest changes so it will be completely compatible with the older .HMI files. Just use it like you are used too.

You can also use the new editor if you rebuild all of the fonts which is a bit more work, but not all that difficult. I have NOT experienced any issues loading or using an older .TFT created with the new editor , even old .HMI files that I rebuilt the fonts on.

The LTS download and instructions on how to replace the fonts are listed in this thread.
viewtopic.php?f=20&t=2014

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by EA3BIL » Fri Aug 09, 2019 9:47 am

As per my personal experience (right now on it...) my 2.4 K series look to "disturb" MMDVM communications.
I get "Unable to read the firmware version after six attempts"

So... Going back to 0.55.

KE7FNS
Posts: 222
Joined: Wed Apr 17, 2019 11:11 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by KE7FNS » Sat Aug 10, 2019 12:27 am

EA3BIL wrote:
Fri Aug 09, 2019 9:47 am
As per my personal experience (right now on it...) my 2.4 K series look to "disturb" MMDVM communications.
I get "Unable to read the firmware version after six attempts"

So... Going back to 0.55.
What .hmi screen did you load? And how have you determined that this issue is caused by the Nextion Editor .58?

Something as simple as a typo in the modem port setting can cause that error. It is also possible the modem firmware has become corrupted and needs to be reflashed.

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by EA3BIL » Sun Aug 11, 2019 9:49 am

I've been throught the tests with TWO displays.
- ORIGINAL 2.4" K Series bought from ITEAD
- CLONE 2.4" T Series bought from Aliexpress seller
Both them have previously worked fine with Editor also on the Dual Hotspot.

Both them got the FW updated while loadind the schema with 0.58 to S131.
Both them showed the same behave on the HS.
(This is, like they were NOT plugged to the modem port on the MMDVM board).

Now I've done "step back" to Nextion LTS software (0.53) and reloaded to both them the schemas.
(I had a copy on HMI files done, as they do not accept to "go to old version")

Both have worked properly on tests and I keep the T series working on the HS.
BTW, when I loaded the schemas on them by using LTS version, FW was "re-updated" to S99 (downgraded in fact)

If you want the HMI files, just let me know... ;)

Could it be some kind of issue affecting only me?.... Maybe yes, maybe not.
This is why I said: "My Experience".

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by EA3BIL » Sun Aug 11, 2019 1:52 pm

BTW,

Now that LTS version is installed...

It's NOT possible to have 0.53 (standard) version installed nor 0.58, both say "There is a newer versin already installed".

FYI...

KE7FNS
Posts: 222
Joined: Wed Apr 17, 2019 11:11 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by KE7FNS » Sun Aug 11, 2019 11:17 pm

EA3BIL wrote:
Sun Aug 11, 2019 9:49 am
I've been throught the tests with TWO displays.
- ORIGINAL 2.4" K Series bought from ITEAD
- CLONE 2.4" T Series bought from Aliexpress seller
Both them have previously worked fine with Editor also on the Dual Hotspot.

Both them got the FW updated while loadind the schema with 0.58 to S131.
Both them showed the same behave on the HS.
(This is, like they were NOT plugged to the modem port on the MMDVM board).
Interesting.

My screens are reporting firmware S130, and I'm not experiencing that issue on either of them.

EA3BIL wrote:
Sun Aug 11, 2019 9:49 am
If you want the HMI files, just let me know... ;)
Yes please, either attach it to a post in this thread, or PM it to me. I'd like to analyze it and see if it is doing something different. I don't have a 2.4" screen, but I should be able to load it in the editor and change its size just for testing purposes.

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: Warning: loading old HMI files into the latest Nextion Editor .58

Post by EA3BIL » Wed Aug 14, 2019 4:41 pm

KE7FNS wrote:
Sun Aug 11, 2019 11:17 pm
Yes please, either attach it to a post in this thread, or PM it to me. I'd like to analyze it and see if it is doing something different. I don't have a 2.4" screen, but I should be able to load it in the editor and change its size just for testing purposes.

Here they are:
(Based on MODEL 8...)

MODEL K024
v053
https://drive.google.com/open?id=1CsHIs ... TKZ5tZHM0H

v058 (if not wrong...)
https://drive.google.com/open?id=1G02TK ... HWK6q2_0fa


NOTE:
I double-double checked wiring and it was always OK.
Weird.... Yes.


NOTE2:
BTW... If you have a K series unit, you don't need to resize, only change the size on the Editor.
It will show "not full screen", anyway it should work.
For testing it's enough...
Problems only show when using on a smaller unit (or wrong "series")

Post Reply