CAN-TRBO not showing in DMR Master dropdown

Help with DMR issues
Post Reply
K1RDD
Posts: 24
Joined: Sun May 12, 2019 10:40 am
Location: New England

CAN-TRBO not showing in DMR Master dropdown

Post by K1RDD » Wed Aug 14, 2019 10:45 pm

Tried rebooting and updating the zumspot and CAN-TRBO is not in the dropdown. Any ideas/suggestions?

VE1AIC
Posts: 27
Joined: Wed Apr 11, 2018 1:55 pm

Re: CAN-TRBO not showing in DMR Master dropdown

Post by VE1AIC » Fri Aug 16, 2019 1:52 pm

This has been an on-going problem with the updates to DMR_Hosts files.
May have to create a local version in root.
The Aug-16 version is still bad.
http://www.pistar.uk/downloads/DMR_Hosts.txt
73, Ron

VE1AIC
Posts: 27
Joined: Wed Apr 11, 2018 1:55 pm

Re: CAN-TRBO not showing in DMR Master dropdown

Post by VE1AIC » Fri Aug 16, 2019 2:16 pm

If you're like me and use DMR+_IPSC2-CAN-TRBO server a lot then it's worth creating a static entry for it.
The file /root/DMR_Hosts.txt is already in Pi-Star so you just need to add this server to it.
SSH in, rpi-rw, then "sudo pico /root/DMR_Hosts.txt".
You can either manually type in the info or Right-click and select Paste from Browser and copy this text into the box.
Be sure to go back and edit the line so that it has TABs instead of spaces.
After Update the server will load it but sometimes at the end of the list, but at least it will always be there.
73, Ron
VE1AIC


DMR+_IPSC2-CAN-TRBO 159622 207.35.36.178 PASSWORD 55555

K1RDD
Posts: 24
Joined: Sun May 12, 2019 10:40 am
Location: New England

Re: CAN-TRBO not showing in DMR Master dropdown

Post by K1RDD » Fri Aug 16, 2019 3:00 pm

VE1AIC wrote:
Fri Aug 16, 2019 2:16 pm
If you're like me and use DMR+_IPSC2-CAN-TRBO server a lot then it's worth creating a static entry for it.
The file /root/DMR_Hosts.txt is already in Pi-Star so you just need to add this server to it.
SSH in, rpi-rw, then "sudo pico /root/DMR_Hosts.txt".
You can either manually type in the info or Right-click and select Paste from Browser and copy this text into the box.
Be sure to go back and edit the line so that it has TABs instead of spaces.
After Update the server will load it but sometimes at the end of the list, but at least it will always be there.
73, Ron
VE1AIC


DMR+_IPSC2-CAN-TRBO 159622 207.35.36.178 PASSWORD 55555
Can this be done via the "expert" option on the configuration page in place of this? If so, how would it look? I'm not a software person (for the last 20 years anyway!)

[DMR Network 2]
Enabled=0
Address=192.241.175.221
Port=55555
TGRewrite0=2,8,2,9,1
PCRewrite0=2,84000,2,4000,1001
Password=PASSWORD
Debug=0
Id=3138325
Name=DMR+_IPSC2-NewYork

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: CAN-TRBO not showing in DMR Master dropdown

Post by EA3BIL » Mon Aug 19, 2019 5:47 pm

CAN-TRBO is not the only one dissapeared...

I also miss:
DMR+_IPSC2-Catalunya 306720 217.61.2.11


I've added it to the CUSTOM area at the end of DMRHots.txt.

It is here:
/usr/local/etc/DMR_Hosts.txt

For those not so pratice to edit files...

Do this way:
Go Config, Expert, SSH.
Enter user & password.
Type: rpi-rw (this provides Read Write permissions)
sudo nano /usr/local/etc/DMR_Hosts.txt (to edit the file. NOTE: Use Upper/Lower case like this Linux is Case Sensitive)
Now use END key on the keyboard to go bottom.
Add whatever you need.
Press CTRL+O (to save the changes)
PressCTRL+X (to exit editor)
Now you can select you server (it will be at the bottom of the list)



SAMPLE:
#
###########################################################################$
#
# Custom DMR Hosts
#
###########################################################################$
# Name DMR-ID IP/Hostname Pas$
###########################################################################$
#BM_Custom_01 1234 1.2.3.4 pas$
#DMR+_Custom_01 1234 1.2.3.4 PAS$
###########################################################################$
DMR+_IPSC2-CAN-TRBO 159622 207.35.36.178 PASS
DMR+_IPSC2-Catalunya 306720 217.61.2.11 PAS$

User avatar
KE0FHS
Posts: 915
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: CAN-TRBO not showing in DMR Master dropdown

Post by KE0FHS » Mon Aug 19, 2019 6:50 pm

You'll have better results if you add your modifications to the DMR_Hosts.txt file (capitalization important) in the root directory; otherwise, the changes you make in /usr/local/etc/DMR_Hosts.txt will get overwritten the next time you run a Pi-Star Update.

For example, using the Nano editor:

Code: Select all

rpi-rw
sudo su -
nano DMR_Hosts.txt
Insert your changes, write your changes, exit the Nano editor, revert to read-only mode (rpi-ro), and then run a Pi-Star Update. The Update will append the modifications to the /usr/local/etc/DMR_Hosts.txt file.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

EA3BIL
Posts: 34
Joined: Tue Apr 17, 2018 11:45 pm

Re: CAN-TRBO not showing in DMR Master dropdown

Post by EA3BIL » Tue Aug 20, 2019 8:59 am

Ok...
I'll do that way.
Thanks for the advice !!

Post Reply