Unrecognized controller , using dummy controller

General support for the Pi-Star System
Post Reply
WD4W
Posts: 2
Joined: Thu Sep 05, 2019 7:00 pm

Unrecognized controller , using dummy controller

Post by WD4W » Fri Sep 13, 2019 9:33 pm

My forum search only turned up display issues. I am having a controller issue with this error "Unrecognized controller , using dummy controller"

This issue puts my pi into debug mode. Any ideas as to what causes this problem?

==============================================
Live Log File content below
==============================================
Pi-Star:4.1.0-RC4 / Dashboard: 20190905
Pi-Star Digital Voice - Live Logs

Dashboard | Admin | Power | Backup/Restore | Configuration
Live Logs
Starting logging, please wait...
M: 2019-09-13 21:24:05: File /root/en_GB.ambe not readable
M: 2019-09-13 21:24:05: Reading /usr/local/etc/dstarrepeater/en_GB.ambe
M: 2019-09-13 21:24:05: File /root/en_GB.indx not readable
M: 2019-09-13 21:24:05: Reading /usr/local/etc/dstarrepeater/en_GB.indx
E: 2019-09-13 21:24:05: Unrecognized controller , using dummy controller
M: 2019-09-13 21:24:05: Starting GMSK Modem Controller thread
M: 2019-09-13 21:24:05: Poll text set to "linux_gmsk-20190118---debug"
M: 2019-09-13 21:24:05: Starting the D-Star repeater thread
M: 2019-09-13 21:24:16: Slow data set to "Not linked "
M: 2019-09-13 21:24:19: Network header received - My: KK4PGE /INFO Your: CQCQCQ Rpt1: KK4PGE G Rpt2: KK4PGE C Flags: 00 00 00
M: 2019-09-13 21:24:19: Transmitting to - My: KK4PGE /INFO Your: CQCQCQ Rpt1: KK4PGE G Rpt2: KK4PGE C Flags: 00 00 00
M: 2019-09-13 21:24:21: Stats for KK4PGE Frames: 2.6s, Loss: 0.0%, Packets: 0/128
Download the log: here
Pi-Star web config, © Andy Taylor (MW0MWZ) 2014-2019.
Need help? Click here for the Support Group
Get your copy of Pi-Star from here.

KE7FNS
Posts: 290
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unrecognized controller , using dummy controller

Post by KE7FNS » Fri Sep 13, 2019 10:56 pm

M: 2019-09-13 21:24:05: File /root/en_GB.ambe not readable, which is odd cause that file doesn't exist at /root/ on my hotspot.

It could be a permissions issue where some file permissions got corrupted, or it might even be a corrupted SD card, but either way theres an issue with it reading specific files for some reason.

I don't think its really worth the time involved in trying to fix it or even figuring out what is wrong, I'd just get another SD card and reflash it and start over on a fresh image. Then I'd test the old SD card to see if it reports any errors, and if it does, you have the answer to your question, if it doesn't then you have a backup SD card.

I also wouldn't try to backup that system and restore it to the new image, I would just start over. If the files are corrupted you'll just be zipping them up and corrupting the fresh image.

I know that isn't the answer you were looking to hear, but good luck.
All views, comments, posts and opinions shared are entirely my own.

ct1dvm
Posts: 142
Joined: Thu Apr 19, 2018 6:34 am

Re: Unrecognized controller , using dummy controller

Post by ct1dvm » Sat Sep 14, 2019 7:33 am

KE7FNS wrote:
Fri Sep 13, 2019 10:56 pm
M: 2019-09-13 21:24:05: File /root/en_GB.ambe not readable, which is odd cause that file doesn't exist at /root/ on my hotspot.

It could be a permissions issue where some file permissions got corrupted, or it might even be a corrupted SD card, but either way theres an issue with it reading specific files for some reason.

I don't think its really worth the time involved in trying to fix it or even figuring out what is wrong, I'd just get another SD card and reflash it and start over on a fresh image. Then I'd test the old SD card to see if it reports any errors, and if it does, you have the answer to your question, if it doesn't then you have a backup SD card.

I also wouldn't try to backup that system and restore it to the new image, I would just start over. If the files are corrupted you'll just be zipping them up and corrupting the fresh image.

I know that isn't the answer you were looking to hear, but good luck.
No, the issue is the modem is not recognised by dstarrepeater, due to bad port configuration or bad connection. Nothing to do with the image, the image is fine.

M1DNS
Posts: 376
Joined: Thu Apr 05, 2018 5:30 am

Re: Unrecognized controller , using dummy controller

Post by M1DNS » Mon Sep 16, 2019 9:21 pm

What hardware are you using?
My guess, maybe ur trying to run a MMDVM device with the dstarrepeater setup.

Andrew M1DNS, (Mod)


Andrew M1DNS.
Pi-star Admin Team.

Post Reply