Pi 0 board not initialized

Help setting up WiFi
KE7FNS
Posts: 448
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi 0 board not initialized

Post by KE7FNS » Wed Oct 02, 2019 9:15 pm

AF6VN wrote:
Wed Oct 02, 2019 4:11 pm
My point was that the OP states THAT IS THE WORKING CARD!

We have no idea what the OP's attempts to create a card contain.
A SD card with only those contents will not boot (try it out yourself), and it also exhibits the exact same scenario that he described in his first post, a solid red LED and no green LED activity. It also does not output any video to a monitor (GPU rainbow color pattern test).

So we must always question the validity of the statements given.
All views, comments, posts and opinions shared are entirely my own.

KE0DVW
Posts: 9
Joined: Fri Aug 02, 2019 3:11 pm

Re: Pi 0 board not initialized

Post by KE0DVW » Tue Oct 08, 2019 12:33 am

I am just so confused by this conversation? I can probably take a movie of the process I use to create a pi-star bootable memory card. Would this help?
Thanks,
Steve

KE7FNS
Posts: 448
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi 0 board not initialized

Post by KE7FNS » Tue Oct 08, 2019 2:56 am

KE0DVW wrote:
Tue Oct 08, 2019 12:33 am
I am just so confused by this conversation? I can probably take a movie of the process I use to create a pi-star bootable memory card. Would this help?
Thanks,
Steve
I doubt a video of that would help.

Again, what I suggest you do is plug in a monitor to the RPi, and watch what it does while it boots.

The first 30 seconds of this video are what is the most important to take away.
https://www.youtube.com/watch?v=3Tw7U5EPYbs

If you see a rainbow image (colorwheel test), and then text scrolling up the screen it is working like it is supposed to. If you don't see anything but a maybe a black or blue screen, or your monitor reports no signal, try writing the image again but this time use a different brand SD card and retest.

Repeat that again and again testing each of your SD cards.

Once you observe the RPi booting correctly, then we can conclude you can write a SD card successfully, and that the RPi can read that card successfully.

Then once you know the RPi boots correctly on certain SD cards, you can begin setting up pi-star using the dashboard.
All views, comments, posts and opinions shared are entirely my own.

KE0DVW
Posts: 9
Joined: Fri Aug 02, 2019 3:11 pm

Re: Pi 0 board not initialized

Post by KE0DVW » Tue Oct 08, 2019 4:08 am

Oh Boy! I should have made a video. You are not going to believe me, but here is what happened:

I used the other image program "Etcher". Etcher would not read from within the zip file. So I unzipped the two files, and burn an image on an PNY sd card that was on the good list from the website you provided. I didn't use the beta software. I used the production version.

Second, I put the SD card into the RPi 3b, with a hat, and booted. I hooked up the RPi 3b to my monitor. It did show the RPi 3b booting. It showed all the pi-star code as failed, approximately 20 calls. Then RPi 3b came to a pi-star prompt.

Third, I got my phone ready to shoot a picture, rebooted the RPi 3b, I got a black screen. The RPi 3b would not send anything to the screen!

Forth, I put the good SD card into the RPi 3b and it came up without errors, and it was functional on the OLED screen.

*** Problem *** I put the good SD card back into the Jumbo Spot with the pi 0. Now the OLED doesn't come up! Darn, what have I broke now? My one and only working SD Card isn't fully working. I don't have a micro HDMI cable / adapter handy. I will need to do some hunting and pecking in my junk pile. Someone said that resetting back to factory config and re-configuring my resolve the problem?
Thanks, Steve

KE7FNS
Posts: 448
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi 0 board not initialized

Post by KE7FNS » Tue Oct 08, 2019 5:58 am

KE0DVW wrote:
Tue Oct 08, 2019 4:08 am
Oh Boy! I should have made a video. You are not going to believe me, but here is what happened:

I used the other image program "Etcher". Etcher would not read from within the zip file. So I unzipped the two files, and burn an image on an PNY sd card that was on the good list from the website you provided. I didn't use the beta software. I used the production version.
Not sure why loading a .zip file doesn't work for you, it works perfectly for me. You can even see in this screen capture it clearly says it supports loading a .zip file. Maybe you are not running the latest stable version of belena etcher or something.

etcher.png
etcher.png (47.57 KiB) Viewed 395 times

It doesn't really matter all that much though since you were able to extract it, it is just an extra step you had to perform.
KE0DVW wrote:
Tue Oct 08, 2019 4:08 am
Second, I put the SD card into the RPi 3b, with a hat, and booted. I hooked up the RPi 3b to my monitor. It did show the RPi 3b booting. It showed all the pi-star code as failed, approximately 20 calls. Then RPi 3b came to a pi-star prompt.
Your original post states you were asking for help to get a RPi Zero functioning, and now this is the first post that mentions a RPi 3B. Little details being left out like that are very important. If you would of been trying to boot pi-star 3.4.17 on a RPi 3B+ it wouldn't of even booted (red flashing LED), due to the 3B+ needing to use the 4.0/4.1 betas.

Now when you said, "It showed all the pi-star code as failed, approximately 20 calls." I assume you mean when you were reading the scrolling text on the monitor it was reporting failures loading the services. Of course that is going to be the case, pi-star hasn't been configured correctly on a fresh install.

The whole point of watching it on a monitor was more about seeing it boot successfully rather than watching for any failures/errors along the way. If the image was written incorrectly or the SD card was unreadable the RPi wouldn't boot in the first place. Since it booted the image is perfectly fine, don't worry about error messages.
KE0DVW wrote:
Tue Oct 08, 2019 4:08 am
Third, I got my phone ready to shoot a picture, rebooted the RPi 3b, I got a black screen. The RPi 3b would not send anything to the screen!
No idea what that was all about, if you power on a RPi without a HDMI cable attached, and then try to plug it in later, it won't display anything maybe that is what happened.

So I can't determine if it even booted or not, was this using the same SD card that just worked previously? How did you shut it down or reboot it back in step 2?
KE0DVW wrote:
Tue Oct 08, 2019 4:08 am
Forth, I put the good SD card into the RPi 3b and it came up without errors, and it was functional on the OLED screen.
I would expect a known working SD card to work.
KE0DVW wrote:
Tue Oct 08, 2019 4:08 am
*** Problem *** I put the good SD card back into the Jumbo Spot with the pi 0. Now the OLED doesn't come up! Darn, what have I broke now? My one and only working SD Card isn't fully working. I don't have a micro HDMI cable / adapter handy. I will need to do some hunting and pecking in my junk pile. Someone said that resetting back to factory config and re-configuring my resolve the problem?
Thanks, Steve
Now you know why I said to put that SD card in a safe place and not to mess with it. No idea why the OLED didn't work. OLED's use an i2c bus to communicate, maybe you have different addresses set for each of your OLED's. They are set by solder pads on the PCB. Or maybe the OLED's are different size .96 and 1.3 which require different settings in the configuration.

The other thing you really need to take into account is that a RPi 3B will boot in a matter of seconds, and a RPi Zero can take upwards of a minute or two before it is ready. It is the difference between one processor, and having 4 doing tasks in parallel. Maybe you didn't wait long enough.

I think what we have discovered is that you aren't really experiencing any issues with writing a SD card and booting a RPi, other than that anomaly you had in step 3.

Now you need to either create the wpa_supplicant.conf file and copy it to the /boot partition and boot the RPi and see if it shows up on your network, or just wait 3 to 5 minutes for the pi-star wireless access point to start and use a laptop or phone to connect to the pi-star network on the hotspot so you can configure it and set your normal wifi settings for the next reboot.
All views, comments, posts and opinions shared are entirely my own.

M1DNS
Posts: 429
Joined: Thu Apr 05, 2018 5:30 am

Re: Pi 0 board not initialized

Post by M1DNS » Tue Oct 08, 2019 8:07 pm

Have a look here to ensure ur correctly burning the image etc.
https://youtu.be/B5G4gYDdJeQ
There are a few how-to videos created by Craig W1MSG
He creates all our pi-star how-to videos.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

KE0DVW
Posts: 9
Joined: Fri Aug 02, 2019 3:11 pm

Re: Pi 0 board not initialized

Post by KE0DVW » Thu Oct 10, 2019 6:07 am

Let's start fresh. I hard wired my RPi 3b to my lan, and I was able to configure everything except Wifi. I can see my Wifi network in the configuration screen, and I try to add my network, but it doesn't appear to connect to the Wifi network.
I first loaded pi-star version Pi-Star_RPi_V3.4.17_20-Jan-2019, and the Wifi wouldn't connect.
Second, I loaded pi-star version Pi-Star_RPi_V4.1.0-RC4_27-Aug-2019, and the Wifi wouldn't connect.
I have swapped the antenna without without any change. The Jumbo spot knows when I press the transmitter button, but it assigns a network IP address of 192.168.50.1, which is not available on my network. Assignable IP address range is 192.168.1.2 to 192.168.1.50. When I press the talk button on the radio, the pistar displays, on the OLED, the correct information except IP address, and doesn't send out anything?

I don't know if it helps but my Radio/Modem type is "STM32-DVM/MMDVM_HS_RASPBERRY PI HAT(GPIO)" The setup program rejected this Radio/Modem type twice, and accepted the Radio/Modem type on the third attempt.

Finally, you can access my Jumbo spot if I put it in the DMZ.

Thank you for your help. I am inching to a resolution.
Steve McManus, KE0DVW

KE7FNS
Posts: 448
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi 0 board not initialized

Post by KE7FNS » Thu Oct 10, 2019 7:33 am

Well, we are making some sort of progress at least.

Ok, from the sounds of it, it is not connecting to the wifi network correctly (which isn't really necessary if you are going to just leave it hooked up wired), so you have a choice to fiddle with the wifi settings until you get it connected, or just leave it plugged into the ethernet cable and you are already finished and ready to use it.

Suggestions for the wifi settings would be to make sure you are typing in the SSID correctly and capitalization matters, it must match exactly. If there are weird characters in the settings or spaces, you might have difficulty because of them.

You could also try to use this: (it is made to bypass those weird characters and spaces but still work)
https://www.pistar.uk/wifi_builder.php

You need to enter your network settings (SSID and PSK), and then save that file to your computer, then grab one of those working SD cards you got booting, and simply drag and drop a copy of the file to the root of the /boot volume. Then when you insert the SD card and boot it, it should try to connect to the network using the settings you entered to build the configuration file. If it works, it will then save the settings on the RPi and you will be fine on future reboots, if it doesn't you might have to change your entire wifi network settings, or figure out what you are typing incorrectly on your own.

192.168.50.1 is the wireless access point it sets up if it cannot connect to wifi after X amount of minutes. It is only useful to connect to it with a phone or a laptop/tablet to configure the dashboard. It will not connect to any digital radio network when it is in that mode.

If you have the RPi hardwired it should already have an ip address on your network, and begin to work fine. If you want to know what the ip address is, go to the ssh access terminal in the admin expert dashboard configuration screen, and type in

Code: Select all

ifconfig 
you'lll see something like this::

Code: Select all

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.3  netmask 255.255.255.0  broadcast 192.168.1.255
whatever is after "inet" is your assigned ip address on eth0 which is the network card associated with the ethernet port.

wireless is wlan0

I definitely wouldn't put it in the DMZ


Looks like you were parroting just fine, if you weren't hearing anything it was either because you didn't talk long enough (4 seconds) or a radio programming issue not listening to the parrot private call.

https://brandmeister.network/?page=hotspot&id=3144458
All views, comments, posts and opinions shared are entirely my own.

AF6VN
Posts: 281
Joined: Fri Jul 20, 2018 1:15 am

Re: Pi 0 board not initialized

Post by AF6VN » Thu Oct 10, 2019 2:56 pm

KE0DVW wrote:
Thu Oct 10, 2019 6:07 am
Let's start fresh. I hard wired my RPi 3b to my lan, and I was able to configure everything except Wifi. I can see my Wifi network in the configuration screen, and I try to add my network, but it doesn't appear to connect to the Wifi network.
In my experience -- somewhat limited -- if there is a wired ethernet connection, the WiFi will not be used. It confused me for some time when I set up my DVMega/R-Pi 3B -- I had a wired connection, kept adding the WiFi information in the control panel (even tried with my cell phone set to access point mode) and never got it to show up on WiFi. Finally, for some reason, I pulled the wired connection and rebooted -- and it's been happy ever since on WiFi. This is, true, different from the behavior of my other 3B running as a web server (with Raspbian Stretch) where both wired and WiFi come up; I had to manually take the latter down as I wanted only ethernet for that.

Addendum: the PI Zero W antenna is a triangle etched into the circuit board https://www.raspberrypi.org/magpi/pi-ze ... na-design/ (and it looks like the 3B+ has a similar design off to the left of the chip with Raspberry logo, as does the 4B)
I have swapped the antenna without without any change. The Jumbo spot knows when I press the transmitter button, but it assigns a network IP address of 192.168.50.1, which is not available on my network. Assignable IP address range is 192.168.1.2 to 192.168.1.50. When I press the talk button on the radio, the pistar displays, on the OLED, the correct information except IP address, and doesn't send out anything?
What antenna? The antenna on the JumboSpot board is for (most likely 70cm, though could be 2m) Amateur transmissions. Unless you've soldered something to the underside of the R-Pi 3B, the WiFi antenna is that silver brick on the edge of the board https://makezine.com/2016/02/28/meet-th ... erry-pi-3/

To my knowledge the radio board mounted on an R-Pi does not have an IP address, and doesn't care about IP data. It just translates between digital RF and binary packets passed to the R-Pi. The R-Pi only is responsible for IP traffic.

192.168.50.1 is the Pi-Star "Auto AP" address (associated with "pi-star-setup" access point). That implies that whatever you have configured is NOT valid, the unit is timing out trying to connect to it, and reverts to access point mode to allow you, on a computer, to connect to it (if your computer is using WiFi to the router, you have to disconnect that and connect to the access point -- which means no internet -- for configuration).

--
AF6VN
Dennis L Bieber

AF6VN
Posts: 281
Joined: Fri Jul 20, 2018 1:15 am

Re: Pi 0 board not initialized

Post by AF6VN » Thu Oct 10, 2019 5:31 pm

Just some add-on comments, probably covered by prior posts...

As long as you have an Ethernet cable attached, what does "ifconfig" report (note: the following is my R-Pi server machine, not the Pi-Star node).

Code: Select all

[email protected]:~$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.252  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::8431:97f5:fc01:6055  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:ce:b1:eb  txqueuelen 1000  (Ethernet)
        RX packets 568131  bytes 53131026 (50.6 MiB)
        RX errors 0  dropped 105  overruns 0  frame 0
        TX packets 28132  bytes 9324464 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
On that machine, I manually took down the WiFi. Bringing up WiFi resulted in (note that it took a few seconds for the IPv4 address to get assigned).

Code: Select all

[email protected]:~$ sudo ifconfig wlan0 up
[email protected]:~$ sudo ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.252  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::8431:97f5:fc01:6055  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:ce:b1:eb  txqueuelen 1000  (Ethernet)
        RX packets 567770  bytes 53110835 (50.6 MiB)
        RX errors 0  dropped 105  overruns 0  frame 0
        TX packets 28057  bytes 9312330 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::3d13:8e31:8ff7:f75f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:9b:e4:be  txqueuelen 1000  (Ethernet)
        RX packets 9646  bytes 788703 (770.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 100  bytes 13074 (12.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[email protected]:~$ sudo ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.252  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::8431:97f5:fc01:6055  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:ce:b1:eb  txqueuelen 1000  (Ethernet)
        RX packets 567806  bytes 53114131 (50.6 MiB)
        RX errors 0  dropped 105  overruns 0  frame 0
        TX packets 28069  bytes 9315106 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.253  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::3d13:8e31:8ff7:f75f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:9b:e4:be  txqueuelen 1000  (Ethernet)
        RX packets 9649  bytes 789231 (770.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 114  bytes 15348 (14.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
If ifconfig shows wlan0 is up, try taking it down (sudo ifconfig wlan0 down) before...
"sudo ifconfig wlan0 up"
and watching for any error messages. If no messages, redo the plain "ifconfig" and see what it shows for wlan0 this time. Might also want to see what "dmesg" reports after bringing the link up... my server box shows

Code: Select all

[582603.841640] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[582603.841656] brcmfmac: power management disabled
[582604.962488] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready


And then there is the matter of what is in the wpa_supplicant configuration (I've obscured the actual SSID and passcode -- the only "special character" in mine is an = (and this IS from my Pi-Star node, not the server R-Pi)

Code: Select all

[email protected](ro):~$ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
ap_scan=1
fast_reauth=1
country=US

network={
        ssid="obscured"
        psk="obscured"
        id_str="1"
        priority=99
}

--
AF6VN
Dennis L Bieber

Post Reply