hdmi wake up

General support for the Pi-Star System
Post Reply
ve2se
Posts: 3
Joined: Sun Nov 03, 2019 9:11 pm

hdmi wake up

Post by ve2se » Sat Nov 09, 2019 4:29 am

After a while hdmi port switch disable , How to wake up the hdmi port ? Or disable the time out ?
ve2se

kc7ngc
Posts: 7
Joined: Fri Sep 21, 2018 2:47 am

Re: hdmi wake up

Post by kc7ngc » Sat Nov 09, 2019 7:20 pm

Need more detail as power management/blanking etc is different across the OS releases and hardware.

Which Model Raspberry PI are you using?
Which version of pistar are you using?

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: hdmi wake up

Post by KE7FNS » Sat Nov 09, 2019 8:53 pm

I wrote this up to help another guy, maybe it will help.

viewtopic.php?f=3&t=2192&p=10633&hilit= ... ank#p10633
All views, comments, posts and opinions shared are entirely my own.

ve2se
Posts: 3
Joined: Sun Nov 03, 2019 9:11 pm

Re: hdmi wake up

Post by ve2se » Sun Nov 10, 2019 3:47 am

i am using a raspbery pi 3+ and Pi-Star:4.1.0-RC4 / Dashboard: 20191101
tnx for reply

kc7ngc
Posts: 7
Joined: Fri Sep 21, 2018 2:47 am

Re: hdmi wake up

Post by kc7ngc » Mon Nov 11, 2019 4:44 pm

Sorry for late reply. IN the ultimate irony, my monitor died over the weekend.

Official documentation from raspbian that documents how to disable screen blanking of text and graphic consoles is here:
https://www.raspberrypi.org/documentati ... ensaver.md
Which should work on the 4.1 beta of pistar.

Be careful when editing the kernel boot command line info as if you type it your card won't boot and you will need to put card into another machine to be able to fix the error. So I recommend backing up the cmdline.txt file someplace before you edit it to make it easier to undo any potential mistakes.

If you are having an issue when monitor is turned off and back on that nothing ever displays again on the monitor you might need to try forcing HDMI detection to allways be on for the raspberry pi.
Do so by editing the /boot/config.txt file on the raspberry pi and try uncommenting the line that says hdmi_force_hotplug=1 by removing the # at the front of the line so the section looks like below. Save the file, then shutdown and reboot the raspberry pi.

Code: Select all

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

kc7ngc
Posts: 7
Joined: Fri Sep 21, 2018 2:47 am

Re: hdmi wake up

Post by kc7ngc » Mon Nov 11, 2019 5:19 pm

Some additional info. For testing purposes you can toggle HDMI display output on and off using the following commands over SSH:

To power off:

Code: Select all

vcgencmd display_power 0
To Power on:

Code: Select all

vcgencmd display_power 1

ve2se
Posts: 3
Joined: Sun Nov 03, 2019 9:11 pm

Re: hdmi wake up

Post by ve2se » Wed Nov 13, 2019 6:12 pm

No luck my tv show hdmi no signal , i have to reboot the pi to have it again to get hdmi signal back on , until time out

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: hdmi wake up

Post by KE7FNS » Wed Nov 13, 2019 6:30 pm

Set hdmi_force_hotplug=1 in /boot/config.txt

That should keep the port alive.
All views, comments, posts and opinions shared are entirely my own.

Post Reply