mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Help setting up WiFi
KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by KE7FNS » Mon Dec 02, 2019 6:24 am

Actually, do you have power management for wifi turned off on the RPi?

I doubt its a DHCP lease issue, as those don't ever really reach their expiration time, they try to get renewed when the expiration time reaches halfway through, so it shouldn't ever get to that point it is not leased unless there is no communication at all.

I don't have any suggestions besides using an ethernet adapter for a while, and maybe seeing if that fails too, that would at least tell you if it does that its something with your router losing a lookup table or if its isolated to the wifi.

Also try using pi-star 4.1 and see if that makes a difference.
All views, comments, posts and opinions shared are entirely my own.

w9mt
Posts: 12
Joined: Mon Jul 15, 2019 2:40 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by w9mt » Mon Dec 02, 2019 3:28 pm

So far, the carpet bomb settings I configured left the mmdvm's still responsive overnight. This is the first time that has happened since I began struggling with this issue on this home wifi network.

I'm going to do what my medical doctor calls "watchful waiting" for now. But I thank you, Craig, for your suggestion. If the problem comes back within a few days, I will also disable WMM APSD.

I'm not ready to "declare success" just yet, but still being responsive overnight is a a very good sign. I'm hoping the disabling of "auto logout" and "idle timeout" did the trick.

I'll report back in a few days, or definitely sooner if this "crashes and burns" like before with the mmdvm's going non responsive to dashboard queries.

73, and Happy Holidays all...
Tony (W9MT)

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by KE7FNS » Mon Dec 02, 2019 7:23 pm

w9mt wrote:
Mon Dec 02, 2019 1:08 am
Under the Basic Configuration>Auto Logout setting, I changed the 30 minute default setting to be "disabled".
That setting is for the web configuration page to automatically kick the admin out if you idle for X amount of minutes (as a security measure), shouldn't have any impact on wifi or any network communications.
w9mt wrote:
Mon Dec 02, 2019 1:08 am
Under the Service>Idle Timeout setting, I changed the 20 minute default setting to also be "disabled".
That setting is for the SSH service, the only time it would be in use is if you SSH'd into the router to run commands in the CLI and left the SSH terminal open, that shouldn't have any impact on wifi or any network communications either.
w9mt wrote:
Mon Dec 02, 2019 1:08 am
Under Merlin's LAN>DHCP tab, I extended the DHCP lease time to 31 days (max'ed out).
That probably just shifted the mean time between failures, so in about 2 weeks or maybe a month you are going to return back to where you can't communicate with the RPi's without a reboot again.
All views, comments, posts and opinions shared are entirely my own.

w9mt
Posts: 12
Joined: Mon Jul 15, 2019 2:40 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by w9mt » Tue Dec 03, 2019 1:30 am

I ran about 18 or 19 hours and then, even after changing the Auto LogOut and Idle Standby settings to "disable", the mmdvm's still went "ignorant" to Dashboard queries.

So, I have just disabled WMM-APSD, as advised and will go back to "watchful waiting". I hope this works.

I don't know where to go after this !!!

...and to the other blogger who asked about ethernet adapters. Those continue to work, as I have an OpenSPOT1 attached that never fails to work.

73, Tony (W9MT)

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by KE7FNS » Tue Dec 03, 2019 2:46 am

w9mt wrote:
Tue Dec 03, 2019 1:30 am
I ran about 18 or 19 hours and then, even after changing the Auto LogOut and Idle Standby settings to "disable", the mmdvm's still went "ignorant" to Dashboard queries.
As expected, those two settings you disabled have nothing to do with your issue.
w9mt wrote:
Tue Dec 03, 2019 1:30 am
I don't know where to go after this !!!
Thats easy, buy the same model router you use at the other place and be done with it.
w9mt wrote:
Tue Dec 03, 2019 1:30 am
...and to the other blogger who asked about ethernet adapters. Those continue to work, as I have an OpenSPOT1 attached that never fails to work.
Again, you should double check and make sure the wifi power management is disabled on the RPi. It could be the wifi is simply going into power save mode and turning off.
All views, comments, posts and opinions shared are entirely my own.

w9mt
Posts: 12
Joined: Mon Jul 15, 2019 2:40 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by w9mt » Thu Dec 05, 2019 4:32 pm

Jason:

Your suggestions have been most helpful, but to proceed, I need to ask some questions.

1. You say try pi-star 4.1 to see if that will fix my issues. My mmdvm uses a pi zero w. I don't believe there is a release beyond 3.4.17 for my hardware configuration. (Am I correct on this?)

2. You also suggest to disable power management for my RPi. I don't see where there is a setting for this for my pi zero w inside of the pi-star load I am running. Does it have a name I don't recognize when I go through the settings, including Expert mmdvm host mode?

3. Lastly, I'm a bit confused why power management would be different between my less capable AC-1900 wifi router in IL versus the later generation AC-3100 I'm using in AZ.

Can you point me in the right direction?

Thank you.

Tony, W9MT

AF6VN
Posts: 278
Joined: Fri Jul 20, 2018 1:15 am

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by AF6VN » Thu Dec 05, 2019 4:46 pm

The only known criteria for R-Pi is that the 4B requires Pi-Star 4.1.x (it needs the base Debian Buster release of Raspbian for boot support). It may be that 3B+ also needs 4.1.x (I don't recall if Jessie was viable on 3B+; Jessie being what Pi-Star 3.x is based upon).

The Pi-Zero should support any version of Pi-Star. Note that the 4.1.x downloads are on the BETA page https://www.pistar.uk/beta/

--
AF6VN
Dennis L Bieber

User avatar
KE0FHS
Posts: 1078
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by KE0FHS » Thu Dec 05, 2019 5:11 pm

The 3B+ and 3A+ also can use 4.0.x, but that beta codeline has been deprecated and isn't available for download anymore, so practically speaking, a new install for the 3B+ or 3A+ requires 4.1.x.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

kc7ngc
Posts: 22
Joined: Fri Sep 21, 2018 2:47 am

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by kc7ngc » Thu Dec 05, 2019 6:19 pm

The ASUS routers are wonderful things when everything is cooperating. But with all the bells, whistles, buttons and whirligigs they can be a pain in the ars to troubleshoot when their advanced features get too advanced for some devices to handle. They have been causing headache for folks who use raspberry pi's with 3d printers and they been having issues similar to this with their Octopi installs.

In almost all cases disabling the WMM-APSD seemed to fix the problem. From the description it sounded like same issue. Where the device can talk on the network to things, but you can't talk to the device. ASUS routers are known for WMM-APSD issues. And since the PI's seem to work on other routers I think its one of the ASUS "Advanced" features causing the problem. When you disabled WMM-APSD, make sure you do so on both bands (2.4ghz and 5ghz), just found a note in another forum saying it doesn't really turn off unless you make sure to disable it for both bands. Even if your devices are only 2.4ghz.

In the rare chance that doesn't fix it, the other culprit could be the SmartConnect Feature (Band Steering). Which basically tries to tell devices to use a different WIFI channel or band for communication. For example it will try to push devices that have 2.4 and 5ghz radios to the 5ghz channel on the AP to increase their speed. But that breaks devices that ONLY have 2.4ghz radios.
https://www.asus.com/us/support/FAQ/1012132/
So if SmartConnect is on, might want to try turning it off.

I do agree that that trying the new 4.1.x beta would be a good step. I am running it on my Pi zero's without a problem. It does include the new kernel which does have new WIFI drivers. Which might allow the pi Zero and the ASUS to coexist peacefully.

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: mmdvm's connect ok and after a period of days or hours ignore pi-star.local access

Post by KE7FNS » Thu Dec 05, 2019 6:33 pm

w9mt wrote:
Thu Dec 05, 2019 4:32 pm
1. You say try pi-star 4.1 to see if that will fix my issues. My mmdvm uses a pi zero w. I don't believe there is a release beyond 3.4.17 for my hardware configuration. (Am I correct on this?)
You can install 4.1 on a RPi Zero W, it has been reported that it boots a bit slower but it will operate the same.

My reasoning is because there have been 2 official OS releases between the raspbian used in 3.4.17, and 4.1. Maybe they handle power management or wifi keep alive differently in the latest OS. It is just another test (that doesn't cost anything but a little bit of time, and maybe a spare SD card you should have laying around) to see what happens and if there is any difference.
w9mt wrote:
Thu Dec 05, 2019 4:32 pm
2. You also suggest to disable power management for my RPi. I don't see where there is a setting for this for my pi zero w inside of the pi-star load I am running. Does it have a name I don't recognize when I go through the settings, including Expert mmdvm host mode?
Yeah it isn't in any of the dashboard settings, you need to go to the CLI to check or change it.

SSH in and type:

Code: Select all

iw wlan0 get power_save
Heres how to turn it off:
viewtopic.php?f=3&t=1726#p7603

I know if the most recent image of pi-star that wifi power save is turned off, but I'm not sure when that setting was disabled in the older 3.x version of pi-star, its possible that you installed pi-star from an image where that option wasn't turned off, and then upgraded to the latest pi-star version, and that option was never disabled because it is an OS configuration setting and not a pi-star setting (I hope that makes sense).
w9mt wrote:
Thu Dec 05, 2019 4:32 pm
3. Lastly, I'm a bit confused why power management would be different between my less capable AC-1900 wifi router in IL versus the later generation AC-3100 I'm using in AZ.
I don't have an answer for that one, there is obviously something different and it would be pretty difficult to find, but maybe when a device no longer connects checking the router log and seeing what it says. I just assumed you had a different brand entirely, hahah.

You might have to break down and try to contact someone that specializes in ASUS routers, or their support and ask them.
All views, comments, posts and opinions shared are entirely my own.

Post Reply