Nextion screen stops loading at "Nextion Driver"

All things relating to the Nextion Screen(s)
EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sat Feb 22, 2020 1:57 pm

Hi all,

This has been eluding me for the last few days and does'nt make a blind be of sense to me.

I am running a 7" Nextion screen, which is paired with a Raspberry Pi 4B (4GB) and I am using a Duplex MMDVM board. (Using a USB to TTL converter)

I am running Pi-Star:4.1.0-RC8 / Dashboard:20200221.

I have reimaged the SD card and another brand new one now around a dozen times and went through the process I have always went through with other hotspots.

I load the image, access the initial setup, go through the process of assigning the correct parameters and in this case for the Nextion screen, I select Nextion - /dev/tty/USB0/ ON7LDS L3 HS

I have tried with both the ON7LDS drivers and the EA5KL drivers but both result in the screen showing NextionDriver and the IP address.

Intermittently I did get the screen to load and on the dashboard the details giving the FW and the TCXO being displayed.

I have the exact same setup on another hotspot right beside it, loaded with the same parameters and drivers and zero issues.
I even went a step further and updated the firmware for the Raspberry Pi 4B but again no dice.

Has anyone encountered this issue as it only appears with this one hotspot and I have built at least a dozen at this stage but have not encountered this scenario.

Any help or guidance would be greatly appreciated.

Thanks

Robbie EI2IXB

KE7FNS
Posts: 773
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion screen stops loading at "Nextion Driver"

Post by KE7FNS » Sat Feb 22, 2020 7:11 pm

EI2IXB wrote:
Sat Feb 22, 2020 1:57 pm
I load the image, access the initial setup, go through the process of assigning the correct parameters and in this case for the Nextion screen, I select Nextion - /dev/tty/USB0/ ON7LDS L3 HS
/dev/tty/USB0/ is not a valid device name. Did you just mistype that here on the forums or is that really what is entered in the configuration?

there should be no / between tty and USB0, and also no ending / it should read "/dev/ttyUSB0"

Check the logs, both the one for MMDVMHost and the syslog where the Nextion Driver reports them separately.

I have seen a case where the Nextion Driver executable would crash and the screen would look like it got stuck and only display the black screen with the Nextion Driver text in the middle of it. When the screen displays what you are describing, what is the status of the nextiondriver.service? If it shows as exited, then the driver is crashing for some reason or another.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Re: Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sat Feb 22, 2020 8:03 pm

Thanks for the reply, sorry yes that was a typo.

This is the current status of the Nextiondriver service, I swapped out the screen in case the other was causing issues but alas no and change the layout from HS to 3.

Unit nextiondriver.servicesudo.service could not be found.
Unit systemctl.service could not be found.
Unit status.service could not be found.
● nextiondriver.service - NextionDriver service
Loaded: loaded (/lib/systemd/system/nextiondriver.service; enabled; vendor preset:
Active: active (running) since Sat 2020-02-22 18:17:18 GMT; 1h 41min ago
Process: 778 ExecStart=/usr/local/bin/NextionDriver -c /etc/mmdvmhost -i (code=exit
Main PID: 783 (NextionDriver)
Tasks: 1 (limit: 4915)
Memory: 27.1M
CGroup: /system.slice/nextiondriver.service
└─783 /usr/local/bin/NextionDriver -c /etc/mmdvmhost -i

Feb 22 18:17:20 pi-star NextionDriver[783]: Sorted CALL table in 502 ms.
Feb 22 18:17:20 pi-star NextionDriver[783]: Disk size : 58600 MB (54648 free)
Feb 22 18:17:20 pi-star NextionDriver[783]: Started with screenLayout 3
Feb 22 18:17:20 pi-star NextionDriver[783]: Started with verbose level 2
Feb 22 18:17:20 pi-star NextionDriver[783]: Found Nextion display
Feb 22 18:17:20 pi-star NextionDriver[783]: Touch display model NX4024K032_011R
Feb 22 18:17:20 pi-star NextionDriver[783]: FW 136, MCU 61489
Feb 22 18:17:20 pi-star NextionDriver[783]: Serial E4692454C3271927
Feb 22 18:17:20 pi-star NextionDriver[783]: Flash size 16777216
Feb 22 18:17:21 pi-star NextionDriver[783]: Starting with network interface wlan0:192
lines 1-23/23 (END)

EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Re: Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sat Feb 22, 2020 8:07 pm

In regards logs and pardon my ignorance, how and where do I check these as I have never had a reason to do so.

Thanks

Robbie

KE7FNS
Posts: 773
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion screen stops loading at "Nextion Driver"

Post by KE7FNS » Sat Feb 22, 2020 10:00 pm

EI2IXB wrote:
Sat Feb 22, 2020 8:07 pm
In regards logs and pardon my ignorance, how and where do I check these as I have never had a reason to do so.

Code: Select all

grep -i nextion /var/log/syslog

Code: Select all

cat /var/log/pi-star/MMDVM-2020-02-22.log
You can also use the dashboard to view the MMDVMHost logs, under the admin section in "live logs"

From the looks of it the service is staying running, there is a "wait for lan" variable that the code might be getting stuck on, do you have that variable declared in your configuration settings for some odd reason?

Do you see the IP address field being populated? or is it just blank with a counter on the far right side that should be incrementing?
On your TTL adapter there should be some TX and RX LED's, are they blinking at all or completely off?
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Re: Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sun Feb 23, 2020 2:26 pm

Yes the IP address in this case being wlan is displayed but nothing else.
On the USB to TTL adapter the red LED is live but nothing else but on occasion it comes alive and everything is normal and all information is displayed, I also changed the USB to TTL adapter just in case.

I am getting a sneaky suspicion that the Raspberry Pi4B is the issue here as it shows the same issues when different MMDVM boards are loaded.

Below are the Nextion Logs :

Feb 23 14:09:15 pi-star systemd[1]: Starting NextionDriver service...
Feb 23 14:09:16 pi-star NextionDriver: NextionDriver version 1.241
Feb 23 14:09:16 pi-star NextionDriver: Copyright (C) 2017...2019 ON7LDS & EA5KL. All
rights reserved.
Feb 23 14:09:16 pi-star NextionDriver: Starting with verbose level 0
Feb 23 14:09:16 pi-star NextionDriver: Warning: NextionDriver with PID 291 already ru
nning !
Feb 23 14:09:16 pi-star NextionDriver: Data files directory: /usr/local/etc/
Feb 23 14:09:16 pi-star NextionDriver: Reading groups from /usr/local/etc/groups.tx
t
Feb 23 14:09:16 pi-star NextionDriver: Read 1370 groups.
Feb 23 14:09:16 pi-star NextionDriver: Reading users from /usr/local/etc/stripped.c
sv
Feb 23 14:09:16 pi-star systemd[1]: Started NextionDriver service.
Feb 23 14:09:17 pi-star NextionDriver: Read 142920 users.
Feb 23 14:09:18 pi-star NextionDriver: Sorted CALL table.
Feb 23 14:09:18 pi-star NextionDriver: Disk size : 29860 MB (27020 free)
Feb 23 14:09:18 pi-star NextionDriver: Started with screenLayout 3
Feb 23 14:09:18 pi-star NextionDriver: Started with verbose level 2
Feb 23 14:09:18 pi-star NextionDriver: Display will sleep when no data received for 6
000 seconds
Feb 23 14:09:18 pi-star NextionDriver: Opening ports
Feb 23 14:09:18 pi-star NextionDriver: /dev/ttyNextionDriver (=/dev/pts/1) <=> /dev/
ttyUSB0
Feb 23 14:09:18 pi-star NextionDriver: Transparent data sockets NOT active
Feb 23 14:09:18 pi-star NextionDriver: Found Nextion display
Feb 23 14:09:18 pi-star NextionDriver: Touch display model NX4024K032_011R
Feb 23 14:09:18 pi-star NextionDriver: FW 136, MCU 61489
Feb 23 14:09:18 pi-star NextionDriver: Serial E4692454C3271927
Feb 23 14:09:18 pi-star NextionDriver: Flash size 16777216
Feb 23 14:09:19 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:20 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:21 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:22 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:23 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:24 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:25 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:26 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:27 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:28 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:29 pi-star NextionDriver: Unable to find the default route
Feb 23 14:09:30 pi-star NextionDriver: Starting with network interface wlan0: 192.168
.0.199
Feb 23 14:09:30 pi-star NextionDriver: Retry to open sockets
Feb 23 14:09:30 pi-star NextionDriver: Opening sockets ...
Feb 23 14:09:30 pi-star NextionDriver: Transparent Connection: talking socket open, f
d=3
Feb 23 14:09:30 pi-star NextionDriver: Try to bind 0.0.0.0 ...
Feb 23 14:09:30 pi-star NextionDriver: Transparent Connection: listening socket open,
fd=4
Feb 23 14:09:30 pi-star NextionDriver: Transparent data sockets active
Feb 23 14:09:30 pi-star NextionDriver: Use Transparent Connection: NO
Feb 23 14:09:30 pi-star NextionDriver: Local port: 40094
Feb 23 14:09:30 pi-star NextionDriver: Remote port: 40095
Feb 23 14:09:30 pi-star NextionDriver: Found Virtual Port [/dev/ttyNextionDriver]
Feb 23 14:09:30 pi-star NextionDriver: Found Nextion Port [/dev/ttyUSB0]
Feb 23 14:09:30 pi-star NextionDriver: Use Transparent Connection: NO
Feb 23 14:09:30 pi-star NextionDriver: Local port: 40094
Feb 23 14:09:30 pi-star NextionDriver: Remote port: 40095
Feb 23 14:09:30 pi-star NextionDriver: Found Virtual Port [/dev/ttyNextionDriver]
Feb 23 14:09:30 pi-star NextionDriver: Found Nextion Port [/dev/ttyUSB0]
Feb 23 14:09:30 pi-star NextionDriver: Use Transparent Connection: NO
Feb 23 14:09:30 pi-star NextionDriver: Local port: 40094
Feb 23 14:09:30 pi-star NextionDriver: Remote port: 40095
Feb 23 14:09:30 pi-star NextionDriver: Found Virtual Port [/dev/ttyNextionDriver]
Feb 23 14:09:30 pi-star NextionDriver: Found Nextion Port [/dev/ttyUSB0]
Feb 23 14:09:30 pi-star NextionDriver: Use Transparent Connection: NO
Feb 23 14:09:30 pi-star NextionDriver: Local port: 40094
Feb 23 14:09:30 pi-star NextionDriver: Remote port: 40095

EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Re: Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sun Feb 23, 2020 2:27 pm

And the MMDVM Log :

M: 2020-02-23 14:20:38.017 MMDVMHost-20191122_Pi-Star-v4 is starting
M: 2020-02-23 14:20:38.017 Built 11:05:01 Nov 22 2019 (GitID #ed7f593)
I: 2020-02-23 14:20:38.017 General Parameters
I: 2020-02-23 14:20:38.017 Callsign: EI2IXB
I: 2020-02-23 14:20:38.017 Id: 2720164
I: 2020-02-23 14:20:38.017 Duplex: yes
I: 2020-02-23 14:20:38.017 Timeout: 240s
I: 2020-02-23 14:20:38.017 D-Star: disabled
I: 2020-02-23 14:20:38.017 DMR: enabled
I: 2020-02-23 14:20:38.017 YSF: disabled
I: 2020-02-23 14:20:38.017 P25: disabled
I: 2020-02-23 14:20:38.017 NXDN: disabled
I: 2020-02-23 14:20:38.017 POCSAG: disabled
I: 2020-02-23 14:20:38.017 Modem Parameters
I: 2020-02-23 14:20:38.017 Port: /dev/ttyAMA0
I: 2020-02-23 14:20:38.017 Protocol: uart
I: 2020-02-23 14:20:38.017 RX Invert: no
I: 2020-02-23 14:20:38.017 TX Invert: yes
I: 2020-02-23 14:20:38.017 PTT Invert: no
I: 2020-02-23 14:20:38.017 TX Delay: 50ms
I: 2020-02-23 14:20:38.017 RX Offset: -50Hz
I: 2020-02-23 14:20:38.017 TX Offset: -50Hz
I: 2020-02-23 14:20:38.017 RX DC Offset: 0
I: 2020-02-23 14:20:38.017 TX DC Offset: 0
I: 2020-02-23 14:20:38.017 RF Level: 100.0%
I: 2020-02-23 14:20:38.017 DMR Delay: 0 (0.0ms)
I: 2020-02-23 14:20:38.017 RX Level: 50.0%
I: 2020-02-23 14:20:38.017 CW Id TX Level: 50.0%
I: 2020-02-23 14:20:38.017 D-Star TX Level: 50.0%
I: 2020-02-23 14:20:38.017 DMR TX Level: 50.0%
I: 2020-02-23 14:20:38.017 YSF TX Level: 50.0%
I: 2020-02-23 14:20:38.017 P25 TX Level: 50.0%
I: 2020-02-23 14:20:38.017 NXDN TX Level: 50.0%
I: 2020-02-23 14:20:38.017 POCSAG TX Level: 50.0%
I: 2020-02-23 14:20:38.017 RX Frequency: 439755000Hz (439754950Hz)
I: 2020-02-23 14:20:38.017 TX Frequency: 434755000Hz (434754950Hz)
M: 2020-02-23 14:20:38.018 Opening the MMDVM
I: 2020-02-23 14:20:40.028 MMDVM protocol version: 1, description: MMDVM_HS_Hat-v1.5.
1b 20191201 14.7456MHz ADF7021 FW by CA6JAU GitID #146e6fb
E: 2020-02-23 14:20:40.049 Received a NAK to the SET_CONFIG command from the modem

KE7FNS
Posts: 773
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion screen stops loading at "Nextion Driver"

Post by KE7FNS » Sun Feb 23, 2020 10:43 pm

I see three things that are a concern to me.

The first is you appear to be running a beta release of the MMDVM_HS firmware and second, you are running EA5KL's modified Nextion driver.

I am not familiar with the changes EA5KL has made or or hasn't made to ON7LDS's most current code, perhaps you should contact him and ask him to provide support for his version of the software.

The last thing is at the end of the syslog. It appears that the code is trying to open transparent sockets over and over, when earlier in the log it said transparent sockets were not active. If it is not using transparent sockets, it shouldn't be in the code section to be setting them up, so I don't know what is causing that. I know if you use a modem connected Nextion you need to have transparent sockets active as that is what I use, but I'm not sure what either on or off does when using a TTL connected Nextion.

Is there a specific reason you are using a TTL adapter? Does the hat you use have a Nextion port?

You could also increase the LogLevel to 4 or 6 to get more details, but make sure to put it back after testing as people have reported that it fills up the filesystem and causes problems.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

EI2IXB
Posts: 9
Joined: Thu Oct 10, 2019 11:17 am

Re: Nextion screen stops loading at "Nextion Driver"

Post by EI2IXB » Sat Mar 07, 2020 6:10 pm

Apologies for the late reply, it transpired that the Pi 4B was in fact defective and once replaced all issues disappeared.

Many Thanks for the support.

KE7FNS
Posts: 773
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion screen stops loading at "Nextion Driver"

Post by KE7FNS » Sat Mar 07, 2020 8:12 pm

EI2IXB wrote:
Sat Mar 07, 2020 6:10 pm
Apologies for the late reply, it transpired that the Pi 4B was in fact defective and once replaced all issues disappeared.
Wow, bad serial port on the RPi?

Well glad its working now and have fun.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

Post Reply