How-To: Enable IPv6 for the Dashboard

General support for the Pi-Star System
Post Reply
HB9EUE
Posts: 18
Joined: Sat May 26, 2018 8:17 am

How-To: Enable IPv6 for the Dashboard

Post by HB9EUE » Tue Jun 05, 2018 10:46 am

Maybe I'm not the only one with the pi-star behind an IPv4 nat but natively reachable via IPv6.

Check it out http://pi-star.woody.ch/(yes, only ipv6 so you won't be able to connect with ipv4)

So what do you need to do, for the dashboard to be reachable via IPv6?
I assume you are familiar with IPv6 and you have a router sending IPv6 RA messages for autoconfiguration of your IPv6 devices in your network and are not using DHCPv6.

Edit: /etc/modprobe.d/ipv6.conf and comment out the line preventing the IPv6 kernel module to be known by the kernel.

# We do want IPv6 in the kernel!
#alias net-pf-10 off
#alias ipv6 off

Edit: /etc/sysctl.conf go to the botton and comment out the disable ipv6 line (=0 did not do the trick for me)
[...]
# Turn off IPv6
#net.ipv6.conf.all.disable_ipv6 = 0

No need to change the Firewall Rules, they are fine!

Edit: /etc/nginx/sites-enabled/pi-star and make sure the Webserver also listens to IPv6:

server {
listen [::]:80 default_server;
listen 80 default_server;
root /var/www/dashboard;
[...]

Then you either restart all affected service, do some sysctl changes manually, load the kernel module manually, or more easily: reboot :-)

73
-Benoit-

Post Reply