Mobile Hot Spot requires power cycling for practical use

General support for the Pi-Star System
AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Mon Mar 16, 2020 7:45 pm

I can't identify my Hot Spot by a brand name as it has none. All I can do is to say, it is one of those sold on Amazon, just search for 'MMDVM Hotspot". They sell for $100-$110 and are roughly 7 cm x 3 cm x 2 cm exclusive of the little antenna. The little screen scrolls MMDVM. Connecting to the device it shows Pi-Star version 3.4.17 / Dashboard 20200221. It is a sandwich of 2 boards, a Raspberry Pi Zero W and a MMDVM (?) board. I use it in DMR mode.

I had hoped to be able to leave this powered in my car all the time for convenience, it only draws 0.175 amp, but after making use of it, then parking the car for the evening, in the morning it displays '-close-'.

In this state, after enabling my cellphone hotspot it typically takes 2 minutes before the Wi-Fi connection is made, then another 6 to 8 minutes before it can be used as a DMR hotspot. I had thought that perhaps disabling Auto AP might change these times, but enabled or not, similar delays before it is useful still occur.

Simply power cycling the hotspot instead makes it available for DMR use in under 1 minute as opposed to nearly 10 minutes if left powered on.

I hope the designers can deal with this delay issue in a future release.
Ron, AE5E

User avatar
MW0MWZ
Site Admin
Posts: 1074
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Mobile Hot Spot requires power cycling for practical use

Post by MW0MWZ » Thu Mar 19, 2020 11:48 pm

I never really designed it to be used that way - the services won't start when there is no internet connection (by design - because what's the point if there is no internet...)

Over-night the Pi-Star software does some housekeeping and updates and stuff - all of that is important enough not to turn it off, so here is what I would suggest.

Add your home WiFi too - so when you are parked up at night, the Pi can still use your home internet, if you add this as the 2nd WiFi entry, any time your MiFi / Personal Hotspot is within range it will use that instead.

Give that a try and see if that solves your issue.
Andy

73 de MW0MWZ
http://pistar.uk

AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Fri Mar 20, 2020 1:48 am

Andy

Unfortunately where I park is out of range of my Wi-Fi. I suspect this is not an uncommon situation. The typical 1 to 2 minutes after I enter my car before the Wi-Fi connection to my cellphone hotspot completes is fine. It is the additional 6 to 8 minutes before it works as a DMR hotspot that is the issue. If that could be shortened considerably it would be ideal.

Thanks for the excellent software.
Ron, AE5E

AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Sat Apr 18, 2020 4:59 pm

Unfortunately the power cycling which is necessary in order to be able to use the hot spot in less than 8 to 10 minutes after entering the car has a drawback. That drawback is corrupting the microSD card due to the power cycling.

Three of us locally have already had this problem. Our current solution is to have image copies written to spare microSD cards which we can swap in when inevitably the power cycling will corrupt the microSD card.

I realize it would be possible from the cellphone to go to the dashboard and command a controlled shutdown everytime you leave the vehicle, but I am hoping that a more convenient solution might be possible.
Ron, AE5E

M1DNS
Posts: 766
Joined: Thu Apr 05, 2018 5:30 am

Re: Mobile Hot Spot requires power cycling for practical use

Post by M1DNS » Sat Apr 18, 2020 5:49 pm

Pistar FAQ page...

viewtopic.php?f=45&t=2576

Sent from my SM-G935F using Tapatalk

Andrew M1DNS.
Pi-star Admin Team.

KE7FNS
Posts: 773
Joined: Wed Apr 17, 2019 11:11 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by KE7FNS » Sat Apr 18, 2020 6:25 pm

AE5E wrote:
Sat Apr 18, 2020 4:59 pm
I realize it would be possible from the cellphone to go to the dashboard and command a controlled shutdown everytime you leave the vehicle, but I am hoping that a more convenient solution might be possible.
You could install a ssh application to your cell phone and login to the RPi and shut it down from the console.

You could add a button (be aware that some scripts use GPIO 21 which is pin 40 which is also used to reset the MMDVMHat and if you attempt to flash the MMDVM hat it will also trigger your shutdown script and interrupt your flashing. So if that is the case you'll need to manually edit the script and wiring and use a different GPIO. )

https://howchoo.com/g/mwnlytk3zmm/how-t ... spberry-pi
https://www.makeuseof.com/tag/add-power ... pberry-pi/

Or you could buy this shim which is designed to sit between the RPi and hat for easy installation. This one shouldn't conflict with MMDVM hats because it uses GPIO 17 pin 11 and GPIO 4 pin 7.
https://www.adafruit.com/product/3581

Or you could use the radio to shut it down.
viewtopic.php?t=792
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Mon Apr 20, 2020 6:43 pm

I have set up PiStar-Remote thus:

[enable]
# Is the Pi-Star Remote Enabled? (true|false)
enabled=true

[dmr]
# TG commands
svckill=9999999
svcrestart=9999998
reboot=9999997
shutdown=9999996

The only changes made from default were enabled=false to enabled=true and removing the #'s from #reboot... and #shutdown... After making the edits I saved them and did a reboot from the dashboard. I then confirmed that the changes had been made.

My callsign, AE5E, is configured in the hotspot and radio. I send via my radio to the hotspot a private call to 9999997 for reboot and 9999996 for shutdown. When sending these the dashboard shows my callsign with those ID's as targets. I get a voice response "Secret not found", but no reboot or shutdown occurs. I am running Pi-Star 3.4.17 20200411.

What am I missing?
Ron, AE5E

M1DNS
Posts: 766
Joined: Thu Apr 05, 2018 5:30 am

Re: Mobile Hot Spot requires power cycling for practical use

Post by M1DNS » Mon Apr 20, 2020 7:50 pm

You didn't mention above that you set your callsign in the Keeper=
section of pistar remote config.
Obvs. It would need your call there.
Default setting is M1ABC, else it's ignoring you.
Sent from my SM-G935F using Tapatalk


Andrew M1DNS.
Pi-star Admin Team.

AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Mon Apr 20, 2020 9:49 pm

Thanks Andrew, I didn't understand the significance of 'Keeper'. I thought the call I had defined for my HotSpot would take care of it. Ill test shortly.
Ron, AE5E

AE5E
Posts: 8
Joined: Sat Mar 07, 2020 11:05 pm

Re: Mobile Hot Spot requires power cycling for practical use

Post by AE5E » Mon Apr 20, 2020 10:38 pm

Configuration for Radio shutdown of a DMR Hot Spot using PiStar-Remote:

Go to Configuration>Expert>PiStar-Remote and for DMR usage configure these items:

[enable]
# Is the Pi-Star Remote Enabled? (true|false)
enabled=true

[keeper]
# Keepers Information
callsign=AE5E

[dmr]
# TG commands
svckill=9999999
svcrestart=9999998
reboot=9999997
shutdown=9999996

After making the above changes, your callsign of course, select "Apply Changes". I then rebooted, probably not needed. I programmed my radio's code plug to include private calls to 9999996 for Shutdown and 9999997 for Reboot. Tested both and they worked!

My intention was to permit me to keep my Hot Spot in my car and control the shutdown without doing a power cycle which had proven to occasionally corrupt the microSD card. I am hopeful this will solve this problem. I will still have to power cycle when I enter the car it appears, but hopefully without corruption. Here are the timings I have found:

After using the hotspot and before leaving the car I send the shutdown command via radio. After a short time the screen scrolls "-close-" Interestingly after sending the shutdown my radio promptly speaks "Secret not found". I don't mind this..it reassures me that the shutdown likely has occured. I leave the hotspot powered, it only draws 0.170 amp. After returning to the car the hot spot I anticipate it will still be scrolling "-close-" (but I won't know for sure until tomorrow morning!). When testing, after it was in "-close-" mode for 30 minutes, I power cycled it and observed that the WiFi connection occurred in 35 second and it became active in DMR mode 2 minutes later. I hope that the power cycling will no longer result in occasional microSD card corruption.

So good so far!
Ron, AE5E

Post Reply