P25 Service crashing after latest update

Help with P25 issues
Post Reply
W7RD
Posts: 30
Joined: Fri Jul 06, 2018 5:48 pm

P25 Service crashing after latest update

Post by W7RD » Fri May 10, 2019 6:43 pm

After doing an update today, I saw on the dashboard that the P25 service (using YSF2P25) was "not started." I tried copying the P25Gateway executable from another machine and it still crashes. Also, I totally reinstalled pi-star and it STILL doesn't work (after an update.) The message it gives on attempted startup is:

P25Gateway: Voice.cpp:113: CVoice::CVoice(const string&, const string&, unsigned int): Assertion `!directory.empty()' failed.
Aborted

Thanks,
Steve

W7RD
Posts: 30
Joined: Fri Jul 06, 2018 5:48 pm

Re: P25 Service crashing after latest update

Post by W7RD » Fri May 10, 2019 7:02 pm

I just noticed that YSF2NXDN isn't working either. The green crossmode and NXDN lights don't even come on.

W7RD
Posts: 30
Joined: Fri Jul 06, 2018 5:48 pm

Re: P25 Service crashing after latest update

Post by W7RD » Sat May 11, 2019 1:35 pm

I swapped out both the Pi AND the Zumspot. Reinstalled fresh AGAIN. STILL P25Gateway crashes on startup. I guess I'm the only person that has any problems with pi-star. Stupid mistake to update it, that's what ruined it.

MW0MWZ
Site Admin
Posts: 912
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: P25 Service crashing after latest update

Post by MW0MWZ » Sun May 12, 2019 6:49 am

Can you run the update a 2nd time please and see if that brings it to life ?
Andy

73 de MW0MWZ
http://pistar.uk

W7RD
Posts: 30
Joined: Fri Jul 06, 2018 5:48 pm

Re: P25 Service crashing after latest update

Post by W7RD » Tue May 14, 2019 5:31 pm

Yes, I tried running the update again, as well as reinstalling more than once. For some reason it always happens. Even switching both the Pi Zero and the Zumspot it persists. Oddly enough, the other ones work with the same version. Not sure what happened with it.

Post Reply